I've tried and failed to get a third monitor working on my Dell Precision tower 7910. It has two Nvidia Quadro K5200 graphics adapters, though when I originally installed Ubuntu 18.04 last week it only had one of the two inserted.

lspci can see both adapters:

$ lspci | grep VGA
03:00.0 VGA compatible controller: NVIDIA Corporation GK110GL [Quadro K5200] (rev a1)
04:00.0 VGA compatible controller: NVIDIA Corporation GK110GL [Quadro K5200] (rev a1)

I've installed the recommended NVIDIA proprietary drivers:

Software & Updates Screenshot

Now, several hours in, I've tried just about everything that I feel comfortable attempting following several forum posts.

Thankfully, I had the presence of mind to install Timeshift beforehand and I have been able to revert back to a working snapshot (though only with two monitors) each time things went south.

The last time I reverted back, I noticed that my live USB stick was able to recognize and display all three monitors. {shrug}

Any thoughts or suggestions?

  • 2
    if you can click edit and enter the web links to what solutions you found online & tried, and the result of each, if could help us avoid trying to reinvent the wheel. – K7AAY Oct 8 '19 at 20:34
  • If you uninstall the Nvidia driver and reboot (so you revert to the nouveau drivers) does that make any difference? From what you tell, I suspect that that's what's making the difference. (Im not saying you should use nouveau, just wondering if it works with that) – rasmus91 Oct 9 '19 at 17:49
  • @user3801839 - Not sure why I didn't think of that - I blame it on burning out my brain going down every conceivable rabbit hole I could find, but uninstalling nvidia drivers and reverting to nouveau did it. Thank you!! – Dan DeFord Oct 10 '19 at 11:57

So my suggestion is, which according to @Dan Deford worked, was to uninstall the proprietary Nvidia driver and use nouveau one instead. Which apparently works.

People should note, however that for 3D acceleration heavy programs (games, etc) the performance of the nouveau driver is generally not up to par with the proprietary one.


Thanks to @user3801839 - here's what I did.

I was having some issues removing the NVIDIA drivers completely as suggested - but I found the following commands to do so here.

Here are the commands I ran to remove the NVIDIA drivers and revert to nouveau:

# LC_MESSAGES=C dpkg-divert --list '*nvidia-340*' | sed -nre 's/^diversion of (.*) to .*/\1/p' | xargs -rd'\n' -n1 -- sudo dpkg-divert --remove
# sudo apt --fix-broken install
# sudo apt purge --autoremove '*nvidia*'
# sudo apt-get update
# sudo apt-get upgrade
# sudo apt-get install ubuntu-desktop
# sudo reboot

Once it rebooted, my third monitor appeared. Thanks again @user3801839!

Note: Do this at your own risk - I was sure to use Timeshift to create a snapshot of my system prior to running the commands above.

One more follow-up -

After removing the NVIDIA drivers, I was struggling with 3D acceleration issues (Blender kept locking up my entire system), so I kept plugging away on this issue.

In the end, I re-installed the same recommended driver and then was looking in NVIDIA X Server Settings. Under the X Server Display Configuration section, there is a checkbox labeled "Enable Base Mosaic" which was not checked. Upon selecting that box, applying the config change, saving out to my X Configuration file, and rebooting, it started working. I'm not entirely sure what Base Mosaic is, but I'm now running proprietary drivers with three monitors.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.