0

Good evening everyone, I have got an issue which I hope you will help me to solve. I was trying to update my Kernel in ubuntu from this web-site http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc4-oneiric/ And everything went smooth. But, for some reason, my wifi doesn't work in new Kernel so I decided to switch back to my old one 3.0.0-17 generic and to my surprise WIFI doesn't start automatically eventhou it was working. What I mean is that I have to click on wifi icon and put a mark Enable Wireless.

This is not a really serious issue but I don't like switch on everytime at log in my WIFI because before that it was working when system started.

What is the cause of this and how to fix it.

Thank you very much for you help.

2 Answers 2

1

You may be have a common issue with a clash between the asus-wmi kernel module and your asus driver.

Suggestion - copy and paste (line by line) the following into a terminal:

sudo modprobe -r asus-wmi

cd /etc/modprobe.d

sudo nano blacklist.conf

Then add blacklist asus-wmi as a new line at the end of the file.

Save and reboot.

11
  • No the problem is not with connecting to the Wifi spot. The problem is when ubuntu starts Wifi is SWITCHED OFF.it is NOT Hard blocked it is Soft Blocked at the start. Commented Apr 1, 2012 at 17:11
  • No, still have to switch on Wireless manually every time at log in. Commented Apr 1, 2012 at 17:21
  • @NikitaKononov Did problem get reloved Commented Apr 1, 2012 at 17:36
  • Thank you very much for paying attention to my issue but still No result. Any other suggestions ? btw When I entered gksudo gedit /var/lib/NetworkManager/NetworkManager.state NetworkingEnabled=true was already true. Commented Apr 1, 2012 at 17:36
  • Yes I noticed mistakes and write commands with "sudo" command before but Still NO result ((( Why this happened if I swtiched back to normal kernel ? before everything worked smooth, any other suggestions ? Commented Apr 1, 2012 at 17:46
0

As per your comments in the question, try this

edit /etc/rc.local, type -

gksu gedit /etc/rc.local

Edit the file so it looks like

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
rfkill unblock wifi
exit 0

Save it and close. After that just reboot and see if it works.

6
  • @downvoter. Please explain.
    – Web-E
    Commented Apr 1, 2012 at 18:19
  • Thank you very much. Your method work. But, I cannot understand, why before installing new kernel everything worked out of the box and when I installed new, logged in it and then get back to previous kernel this happened. Commented Apr 1, 2012 at 18:26
  • Actually it is a fix, Not a solution. The system disables the wi-fi, you are running rkfill unblock command at system start up to unblock. I saw some weired problem with wi-fi card having integrated blue-tooth and linux generic drivers in my own laptop.
    – Web-E
    Commented Apr 1, 2012 at 18:33
  • but mine worked perfectly fine before I installed new Kernel, tried it and then switched back to the previous one. Then I faced this problem. Could it be possible that config files from new kernel conflict with old ones? Commented Apr 1, 2012 at 18:37
  • Yes. Possibly some config file got altered.
    – Web-E
    Commented Apr 1, 2012 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .