114

I have messed up my sudoers file and I want to change the permission on it.

When I login in recovery mode, I cannot run the command chmod as it is read-only option.

I tried mount -o remount,rw / in recovery mode. Didn't work for me:

Err : Ext4-fs remount. Opts errors=remount-ro 

How can I boot into recovery mode and with read-write option?

195

I did some web searching on "Recover Mode Read Only" and came across this post on LinuxQuestions.org website.

  1. Shutdown the computer
  2. Boot into Recovery Mode --After BIOS load, hold down Shift key to access the grub menu --Once in grub menu, select the entry ending in "(recovery mode)"
  3. From the next menu selected option to enter Root Session
  4. At the root session, execute command mount -o rw,remount / to remount the filesystem as read-write
| improve this answer | |
  • I get: "mount: special device remount does not exist" – Rishabh Agrahari Feb 3 '19 at 18:54
  • 1
    @RishabhAgrahari You'll get that message if you added a space after "rw" in the command (ask me how I know :) ). It's as-written: mount(space)-o(space)rw,remount(space)/ – 8bitartist Apr 27 '19 at 5:22
  • @8bitartist Lol, true. Why is it like this? – Rishabh Agrahari Apr 28 '19 at 6:04
19

I always use following way to change into read/write mode

  • Login in Safe Mode
  • From the Menu just go to Grub option, it will give a message like Updating grub will mount your system in read/write mode. Just chose yes to mount your system in read/write mode. It will update your grub and will exit from Grub menu.
  • Finally login as root, your system will be in read/write mode.
  • You can also chose dpkg option from the menu to change file system to read/write mode.

It always worked for me. It helps when you don't remember the command to change into read/write mode.

Just give it a try..

| improve this answer | |
  • what does "login in safe mode" mean? – gman Oct 10 '18 at 0:43
  • @gman: Safe Mode is kind of login without the GUI part! You can do so by holding Shift while your system restarts. You'll get a GRUB menu from where you can choose to login in SAFE MODE – Saurav Kumar Oct 15 '18 at 14:50
  • @gman recovery mode – mchid Jul 30 '19 at 7:12
19

Since the answer is a bit old and did not work for me, I share with you my solution. I mistyped an option in fstab for the / directory (very bad, I know).

In order to mount in recovery mode with read write option the mentioned solutions did not work for me.

I simply chose the kernel with recovery mode option and pressed e to modify the boot parameter from ro to rw.

| improve this answer | |
  • 1
    +1 for an alternate solution, even if it might not be ideal in many cases. – Stunts Sep 18 '15 at 23:22
  • 2
    Your answer is gold! – reexmonkey Aug 9 '19 at 15:11
  • Finaly... Best solution – Vitalicus Jan 21 at 23:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.