0

Midway while upgrading from 18.04 -> 19.04 the computer got restarted.

Encryption and decryption work but I cannot get to a login screen.

The files are viewable from a live USB so I made a backup, and I think I'd just like to reinstall. Before I do I was wondering if from my live USB could I decrypt and reinstall just the OS files and preserve everything else?

Recovery mode doesn't allow networking for whatever reason and I've tried everything I could find online leading me to believe DNS resolving got broken. And no, adding 8.8.8.8 or 1.1.1.1 doesn't help, I really have tried everything and outside of pinging, I can't do anything in recovery mode in regards to finishing the upgrade of the packages which is infuriating.

I remember Windows having a similar feature where you could preserve files and installations and most configs while getting a fresh system install. How can I achieve similar thing in Ubuntu?

  • While they were being installed I believe. The terminal locked me in some menu so I pressed ctrl-c and then it stopped the update process and then the packages said held back, and out of stupidity I thought I should restart it. dpkg --configure -a throws some kind of an error I don't remember. – Squid Oct 8 '19 at 13:27
  • @Kulfy It said it was being used by another process, needed to get the PID and close it a couple times. Finally dpkg would run but nothing happened. Network still won't resolve but I can ping things with 0 packet loss. It says what packages I need to upgrade but apt upgrade won't work since no network, same for apt update. I've plugged in the ethernet and unplugged it to no avail. – Squid Oct 8 '19 at 16:17
  • @Kulfy All the sources are correctly configured to disco and bionic sources are commented out. – Squid Oct 8 '19 at 16:57
  • @Kulfy us.archive.ubuntu.com/ubuntu "name or service not known" when I try to ping. – Squid Oct 8 '19 at 17:02
  • I can only ping IPs which leads me to believe it's some DNS thing. – Squid Oct 8 '19 at 17:04
0

Very strange issue. I needed to add: nameserver 8.8.8.8 to /etc/resolv.conf after running: sudo dpkg-reconfigure resolvconf and restarting the network manager with: service network-manager restart

Not sure if I fixed it accidentally another way, but this is what fixed this very specific and strange issue. I still can't get to the login screen but that is a separate issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.