2

I was wondering if I could hide the Wallch icon from the top bar on my Ubuntu 18.04. It is for student use in my high school. Have any ideas?

1

You could install Hide Top Bar Gnome Extension.

enter image description here

Alternatively you could install Icon Hider Gnome Extension.

enter image description here

After installation, simply move the slider to ON (or OFF if later you wish to disable it).

|improve this answer|||||
2

WorkAround

wallch icon is shown when the extension gnome-shell-extension-appindicator is turned on and when wallch is running..

when you install wallch it has pre-set preferences to auto start after 3secs..

so If you ever use wallch.. you can simply go to preferences and untick "Start wallch on system startup" option. But when ever you open wallch the icon will be shown.

enter image description here

if you turn off gnome-shell-extension-appindicator nothing will be shown but the downside is It will not show any indicator in the topbar as this extension is turned off..

useful links:
How to disable 3rd party app tray icons/indicators in Ubuntu 18.10?
How to remove app icons in system tray Ubuntu 18 GNOME

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.