10

I just installed Kubuntu on my Dell XPS 15 9570. Everything is working fine, except for tap to click on the touchpad.

I can activate the option in the settings but this has no effect.

4 Answers 4

17

After some additional searching I found the solution to my problem here

I had to add Option "Tapping" "True" to the entry MatchIsTouchpad in the file /usr/share/X11/xorg.conf.d/40-libinput.conf. The exact name of the file might be different for other people.

In the end, the relevant section will look like something like this:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        Option "Tapping" "True"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

You need to be root to edit the file and reboot your system after the changes!

4
  • 1
    This worked for me on my XPS also. Mar 26, 2020 at 16:14
  • 1
    This worked for me on Lenovo ThinkPad E580 and E590 (2 different laptops) Oct 20, 2020 at 16:22
  • 1
    This worked on Lenovo G560 with KDE neon 5.22.
    – PS Nayak
    Jul 25, 2021 at 16:47
  • 1
    Thanks! Now tap-to-click even works on the login screen :)
    – wedesoft
    Feb 10 at 20:37
3

You can hit ALT+F2 and search for "Touchpad" under "System settings".

When you get to it, you'll need to set "Tap-to-click" option.

Additionally, you may want to set "Invert scroll direction (Natural scrolling)", which changes how your two finger scrolling works.

For both these options, you can hit "Apply" and see immediately if it suits you. Enjoy!

0
0

IMHO Symlinking the 40-libinput.conf is a better approach. See the Arch Linux libinput wiki.

It works great for me on my Dell Inspiron 7390 with Arch Linux Gnome and Kubuntu 21.04 dual boot. I can also confirm that tap to click works on both Arch Linux gdm and Kubuntu sddm.

sudo ln -sv /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/40-libinput.conf

My modified /usr/share/X11/xorg.conf.d/40-libinput.conf touchpad section looks as follows

    Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on" #added
        Option "NaturalScrolling" "on" #added
    EndSection
1
  • From what I understand that is true only if you have both libinput and synaptics driver on the system and if you were to have their configs in /usr/share/X11 the latter one takes precedence due to it having a higher number 70 assigned to it. But if you modify and symlink libput to /etc/X11 then it gets precedence over config files in /usr/share. This is only beneficial if you have both synaptic and libinput installed on the system Oct 27, 2021 at 4:29
0

This is a minor update, but as it touches on more than one point it's worth a post instead of a comment on a post.

As noted, editing the /usr/share/X11/xorg.conf.d/40-libinput.conf file works well. However, one does not need to reboot after. One only needs to log out and log in as this causes an X11 restart, saving time. Also, if you have other logged in users, this prevents interruption to their work.

My process worked like this:
Open and edit the file from a terminal using:
sudo vim /usr/share/X11/xorg.conf.d/40-libinput.conf
such that my file looks like this.*:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        # added Tapping entry on Oct 22 2021 per
        #   https://askubuntu.com/questions/1179275/enable-tap-to-click-kubuntu
        Option "Tapping"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection
  • Note, I've learned the hard way to always document where I've made a change and WHY I made the change, ideally with a reference to the documentation that led me to the change. In that way, I can follow up later to see if that advice has changed.
1
  • This does work as intented. But, at least on KDE Neon, the 'Tap-to-Click' option is still greyed out and not enabled, so people should be aware of that.
    – Juan M
    Nov 27, 2021 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.