0

I'm trying to install Ubuntu 18.04 (dual boot / alongside Windows) on my Lenovo Yoga 520 with the InsydeH20 BIOS Setup Utility, but I have the following problems:

  1. I cannot disable fast boot. I know that disabling the option is needed for a correct installation, but disabling it in the boot menu has no effect. Turning off the computer and checking the boot menu again yields seeing the "Fast boot" option as active (the BIOS battery should not be dead as other options survive)

  2. The installer sees no partitions. When trying to install the OS, the installer doesn't show me any partitions to select.

I managed to fix one problem though: I used to get the error "MODSIGN: Couldn't get UEFI db list" but managed to "fix" it by resetting some keys in the boot menu (now I only get the error "Couldn't get size: 0x000...").

I have already disabled fast startup in Windows but it doesn't seem to have any effect as can be seen here... My only idea for the cause would a broken hybernation file.

EDIT: I have the Intel RST Option in my bios Setup activated. Do I Need to switch to AHCI?

I accept any advice, thank you in advance.

  • Some bios will only change some things if you make a password for bios. – crip659 Oct 6 '19 at 23:00
  • 1
    Fast Boot must be turned off in Windows; are you thinking of Secure Boot? – ajgringo619 Oct 6 '19 at 23:25
  • @ajgringo619 some bios have a fast boot option also. Not sure if it replaces Win fast boot. My new(refurb) dell has a fast boot option in bios, did not find it windows. – crip659 Oct 6 '19 at 23:34
  • Can also check this link for missing partitions. askubuntu.com/questions/441186/… – crip659 Oct 6 '19 at 23:35
  • 1
    Fast Boot in UEFI may not give you time to press a F-key to get into UEFI or one time boot key to select what to boot from UEFI. It assumes no system changes and immediately starts boot. So if changing system, UEFI fast boot needs to be off to get UEFI to update configuration it reports to operating system. Windows fast start up must be off. And in Windows add the AHCI driver and then in UEFI change to AHCI. Have you also updated UEFI from Lenovo and if SSD updated firmware for SSD? UEFI update may reset some settings back to default to check those also. – oldfred Oct 7 '19 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.