0

I have 2 versions of OBS in my Ubuntu 18.04 LTS. One is OBS 21.0.2.-modified (or obs-studio --candidate), other is OBS studio 24.00.

The problem is when i installed the newer version, i didn't get just an upgrade from 21.0.2. to 24.00, i got TWO snaps at the same time. Probably coz candidate version was in different branch of snap development or something. Not a big deal, but...

The biggest problem is that now both versions can't work right and both miss some functionality. For instance, 24.00 don't show up in tray (which is a life saver during busy broadcast). Also when i chose OBS Studio icon (which is obviously 24.00, coz 21.02 was just "OBS"), only 24.00 version is launched! At that moment i can see how one version interfere with another in tray, which is hillarious). I double checked what version is in tray, and it was exactly 24.00.

(What is weird, also, that built-in Ubuntu software manager can't see V24. Ubuntu Software center can't see it too. Snapcraft site by Canonical can't find it also. It can only be found by clicking direct link in Snapcraft but that's beside the point.)

Logical thing would be delete the old version in terminal BUT... when i use "sudo apt-get remove obs-studio", BOTH version are deleted. When i use "sudo apt-get remove obs-studio 21.0.2-modified", or "sudo apt-get remove obs-studio --candidate", or just "sudo apt-get remove obs", Ubuntu can't understand the command or tell me that "OBS is not installed". I used "purge" but with the same result.

I used snap managers like Stacer and Synaptic.

(I can clarify that OBS is a snap, you can see it for yourself - heresnapcraft.io/obs-studio and here (Stacer clearly shows OBS in a Snap category) Also Synaptic surely works with OBS and shows both versions but calls it "packages". picture of Synaptic showing me two versions By snap manager i mean this one piece of software github.com/oguzhaninan/Stacer.)

First one can see nothing but 24.00. Second one sees older version but somehow can only INSTALL it, but no unistall option! When i try to use "uninstall completely" in Synaptic it can only see 24.00.

Using apt policy obs-studio i get this

apt policy obs-studio
obs-studio:
  Установлен: 24.0.0-0obsproject1~bionic
  Кандидат:   24.0.0-0obsproject1~bionic
  Таблица версий:
 *** 24.0.0-0obsproject1~bionic 500
        500 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     21.0.2+dfsg1-1 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

Can i somehow erase the 21.02.-modified version? WITHOUT the complete removal and new install (coz there will be an incredible amount of work to create all the scenes and FX again).

(Note: I'm a total noob, i use Ubuntu coz i'm too tired of Windows, and everything is cool but this little problem).

  • 1
    I'm thoroughly confused - I cannot tell if you are using debs or snaps or one of each. Tools like synaptic and apt-get handle debs ONLY - they have never heard of snaps. I'm not sure what you mean by a "snap manager" so please edit your question to clarify. Software center will tell you which type of package (deb vs. snap) each version is. Please edit your question to make clear which is which. – user535733 Oct 5 '19 at 3:31
  • i can clarify that OBS is a snap, you can see it for yourself snapcraft.io/obs-studio)... Also Synaptic surely works with OBS and shows both versions but calls it "packages". I'm just confused as you are... PS - by snap manager i mean this one piece of software github.com/oguzhaninan/Stacer – user1002555 Oct 5 '19 at 9:25
  • 2
    Synaptic doesn't do snaps, so you must have both the .deb and the snap installed. This is likely the cause of your issue. Consider an edit to your question showing the result of apt policy obs-studio. Only the 21 version is in the base repos, so you must have a ppa installed. If you provide more information about what you have done, the situation should be fixable. – Organic Marble Oct 5 '19 at 13:55
  • Thanks a lot. Updated the post. So 24.00 version is PPA, and 21 is from,, i don't know. – user1002555 Oct 5 '19 at 17:06
  • OK. So, you have version 24 installed as a .deb from a PPA. Version 21 is not installed as .deb, it is merely listed as available in the normal universe repo. Now, I don't use snaps and can't advise about them - so this should not be considered definite advice - but if you indeed have a snap version installed as well, it seems to me that you should choose which one you want to use, and uninstall the other one. If you really have a version 21, maybe it's the snap, so get rid of it? – Organic Marble Oct 5 '19 at 17:59
0

I solved it by just deleting the 21 version Snap via Software manager, and v24 that was installed from PPA stayed.

  • Thanks for editing my answer, But the legitinacy of the site is under question now. If people can edit your answer freely how can you trust anything else? – user1002555 Oct 8 '19 at 9:35
  • You are new here. That's how it works here, so there is no question about the "legitimacy of the site" Read this for more information: math.stackexchange.com/help/editing – Organic Marble Oct 8 '19 at 22:27
  • Now i understand how the house rules. Cool. But It's not about me and please don't make it or take it personal. – user1002555 Oct 9 '19 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy