3

I have troubles installing drivers for my TP-LINK Archer T3U on Ubuntu 18.04.

Having found out the device ID 2357:012d, I used this repo by @Jeremy31.

Namely, I downloaded the content, cd'ed into it, did make and make install.

What to do next?

sudo dkms add ./rtl8822bu

gives

Error! Could not find module source directory.
Directory: /usr/src/.-rtl8822bu does not exist.

How to properly install the driver?

  • Did you try sudo insmod rtl8822bu.ko and/or sudo modprobe...? – ubfan1 Oct 4 '19 at 23:14
  • @ubfan1 Both give not found – Rubi Shnol Oct 4 '19 at 23:31
  • Not sure if it helps, but in my case it compiled to 8822bu.ko – Mehdi Sadeghi Nov 28 '19 at 15:23
1

Since you are in the rtl8822bu directory, try

sudo dkms add .
sudo dkms install 8822bu/1.1

| improve this answer | |
  • The 1st one seemed to work, but the second gave me Error! Could not find module source directory. Directory: /usr/src/rtl8822bu-1.1 does not exist. – Rubi Shnol Oct 5 '19 at 9:56
  • 1
    Try the sudo dkms install command as I just edited – Jeremy31 Oct 5 '19 at 11:28
  • It worked now, but I got Good news! Module version v5.1.0-5_17968.20160601_BTCOEX20160411-1400_beta for 8822bu.ko exactly matches what is already found in kernel 4.15.0-65-generic. DKMS will not replace this module.. Whereas lshw -C network doesn't list the TP-LINK adapter, like nothing happened – Rubi Shnol Oct 5 '19 at 11:56
  • 1
    You may need to disable Secure Boot – Jeremy31 Oct 5 '19 at 14:24
  • hi @jeremy31 would this driver work with kernel 5.3 in Ubuntu 19.04? I've got another USB adapter (RTL8192EU) that needed patch for kernel 5.3 ( github.com/CGarces/rtl8192eu-linux-driver/tree/CGarces-patch-1 ) Many thanks. – Jags Oct 6 '19 at 18:54
7

As I am running kernel 5.3.4 in Ubuntu MATE 19.04, for me it was the drivers from Cilynx's GitHub repo for RTL88x2BU that worked out OK.

As detailed in the repo, I've installed the drivers using DKMS installation method:

git clone https://github.com/cilynx/rtl88x2bu.git
cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu
| improve this answer | |
4

I am on Ubuntu 19.10 and @Jags solution was the only one that worked for me. Thank you!

git clone https://github.com/cilynx/rtl88x2bu.git
cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu
| improve this answer | |
  • Thank you for this script! It worked for me on Mint 19.3 – ORcoder Mar 10 at 7:12
  • 1
    You don't need to create a new Answer and exactly copy/paste the previous answer just to say it works. You could put a comment under his answer and say it works :) – Kamiel Ahmadpour Jul 2 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.