5

I'm trying to fully install Xubuntu on a 16 GB USB (with persistence). After several atempts, I still can't boot on it.

The ISO was burnt onto the USB using the last version of Rufus with the persistence enabled. After booting from the USB, my screen shows:

[        7.990790] Couldn't get size: 0x800000000000000e

(initramfs) stdin: Invalid argument  
stdin: Invalid argument  
mount: mounting /cow on /root failed: Invalid argument

What am I missing? Thanks in advance.

7

Persistent partitions are only working with latest Rufus using Ubuntu 19.10 and later.

Rufus 3.8 worked great for me using the daily release of Eoan Ermine.

Ubuntu 19.10 is now in Beta and will be released on October 17.

  • 1
    +1. I'm looking forward to 20.04 next spring. I might make the switch from 16.04 then. – WinEunuuchs2Unix Oct 6 at 1:50
  • 1
    Note: The reason persistent partitions are not working with Ubuntu 19.04 or earlier is because of this bug: bugs.launchpad.net/ubuntu/+source/casper/+bug/1489855, that has only been fixed in 19.10. – Akeo Oct 7 at 11:20
  • @Akeo: Is it a syslinux thing? Grub Live installers like mkusb and looped ISOs work with 14.04 to 19.04 and persistent partitions. Syslinux Live installers like UNetbootin, Universal and Rufus did not. – C.S.Cameron Oct 8 at 21:19
  • No, it's a generic bug. You will run into it (on UEFI systems, but if you know your way around Syslinux you can also show it on BIOS) if you simply create a FAT32 partition, copy all the content from a pre 19.10 ISO onto it, then create a second persistent partition after the FAT32 one, format it to ext2/ext3/ext4 with label casper-rw and add the persistent kernel option to the boot/grub/grub.cfg. This very generic (and relatively easy) method of enabling persistence should always have worked, but didn't until 19.10, due to the rather unfortunate bug above... No Syslinux required. – Akeo Oct 8 at 23:33
  • 1
    Basically, the Ubuntu scripts that are supposed to detect and mount a persistent partition have been broken for years and I explained precisely how that happens in the comment I left for the bug report here: bugs.launchpad.net/ubuntu/+source/casper/+bug/1489855/comments/…. Depending on whether you are working with a persistent file or an external partition, the bug will not trigger, but as soon as you use the fairly standard configuration I highlighted above, you will run into it, which makes it all the more puzzling why more people haven't reported that they were impaired by this. – Akeo Oct 8 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.