I have had a problem with my sound for a while now. Sound comes from my headphones, but not from my speakers. I am running Ubuntu 11.10 on a Compaq 320. I have searched around, but none of the threads have worked, some had made it worse (no sound at all, but I managed to get back to where I am now). Any help would on how to fix this would be great.


try using these commands

sudo apt-get update
sudo apt-get upgrade
sudo apt-get purge linux-sound-base alsa-base alsa-utils
sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop


if this not help trying running this script

| improve this answer | |
  • Hey Gaurav, Tried the commands but no luck. he script seems to be outdated for 10.04. would it still work for 11.10 – forrest Apr 1 '12 at 21:40
  • Hey @twister_void, I suggest you to specify on your answer that the display manager to be used is lightdm by default, because these lines - sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop - could lead to set the gdm3, where you know better than me that lightdm is the default one – Giorgio Vitanza Jul 31 '17 at 19:02
  • This worked for me on Ubuntu 18. After many many other attempts! – jouell Feb 22 at 19:44

I found a post in this Ubuntu forums thread answer #2 with a weird solution that works for me.

Boot the system, log in, close the laptop screen, wait for a few seconds, and open it again. Log back into the system and problem solved!!!

| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kevin Bowen Feb 25 '17 at 15:24
  • On mine, it works a while, then soon it is get muted again ( no sound ) after around 1 minutes :( – Bayu Jun 3 '19 at 5:13
  • For now it worked for me – judasane May 1 at 21:40

You need to edit this file /etc/modprobe.d/alsa-base.conf and then add a line in its end. Use the following commands:

sudo gedit /etc/modprobe.d/alsa-base.conf

Now add the following line at its end:

options snd-hda-intel model=generic

Now reboot your computer. It should solve your problem.

Further information:

  • hxxp://www.computerandyou.net/2011/06/how-to-solve-no-sound-through-laptop-integrated-speakers-in-ubuntu-11-04

The link that was posted here is no longer safe to use, and has had its actual link components stripped. The original link is left here for historical purposes, though the link is defused.

| improve this answer | |
  • Hey Abishek, after sing the command, gedit didn't open, so i couldnt add the other line. Why wouldnt gedit open? – forrest Apr 1 '12 at 21:46
  • I was able to open gedit with the command (had to take out the '&' and the end). – forrest Apr 1 '12 at 22:24
  • But after adding the line, there was still no sound from the speakers. – forrest Apr 1 '12 at 22:24
  • @forrest did you try the solution given in the link? It may depend on the sound card as well... the solution worked for me.. – abhishek Apr 2 '12 at 8:17
  • YEa, no luck from the link. my soundcard is '0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]" so its pretty straight forward – forrest Apr 2 '12 at 13:06

I have the same issue on an Aspire.

What's worse I convinced someone to use Ubuntu! Egg on my face!

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.

$ head -n 1 /proc/asound/card*/codec#*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC888

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040

==> /proc/asound/card0/codec#2 <==
Codec: Intel Cantiga HDMI

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ uname -a
Linux salvatore-Aspire-7730 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

The alsa-base.conf does not exist.

Ubuntu 12.04LTS 64bit

Tried this:

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload


sudo apt-get purge pulseaudio gstreamer0.10-pulseaudio
sudo apt-get install pulseaudio gstreamer0.10-pulseaudio indicator-sound

Now audio comes out of both headphone and speaker.

| improve this answer | |

on my lenovo this works:

  • shut down the laptop
  • take off the battery
  • press the power button, to empty the capacitors or wait for 30 seconds
  • put the battery back
  • power on and enjoy sound in headphones again
| improve this answer | |
  • It is not necessary to wait, without the battery press the power button, to empty the capacitors, after that, put the battery back. It worked! – eloyesp Sep 1 '16 at 17:25

I find that sometimes all I have to do is choose the correct output by just going to System Setting and then click on Sound on the output tab. Hope this helps.

| improve this answer | |
  • Tried that out to no avail, however the 'test speaker' didnt make a sound, but i had a video going on youtube that I could hear. – forrest Apr 17 '12 at 18:41

I had the same issue. Go to "System Settings" select "Sound" and then select "Headphones" as the option in the the "Connector" drop down menu list.

| improve this answer | |

You can adjust the sound settings for USB using:

  1. Go to sound settings from the volume options on the right.
  2. I you have plugged in USB speaker then it shows setting options as Analog Output Analog Audio.
  3. Click on it and adjust volume.
| improve this answer | |

I had the same issue on a brand new laptop Asus R417B. I installed Ubuntu 18.04 over the windows disk. Windows had never been installed let alone run, so the speakers had not been used at all.

In pavucontrol the speakers and the headphones are listed, and the volume bar showed sound being played. The speaker test did not produce sound at the speakers. The headphones, when plugged in, worked perfectly.

My fix was trying to try audio over HDMI on the television. The laptop speakers started to work as soon as the laptop was connected over HDMI. Even after disconnecting the HDMI the speakers kept working. Even after a complete power shutdown and restart.

Then the HDMI sound seemed not to work, but that was easy to fix with fiddling with the profiles in pavucontrol.

My conclusion is that the problem was a bug (at least definitely not a feature) in initializing the hardware/software with the speakers.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.