3

I have a 1TB HDD that I use on Windows for file storage, and I would like to share this storage between Windows and Ubuntu (dual boot). But I can't seem to be able to mount this drive in Ubuntu. I can only see the drive in GParted and in the Discs utility. In both it is stated that the file system is unknown. I've already tried mounting it in several ways, but with no success. It seems that the drive, although NTFS formatted in windows, is somewhat formatted to be a storage device in Windows.

So, the real question is, is there a way to convert this HDD or partition without losing data, to be functional in both operating systems?

6
  • 1
    Have you turned off fast startup in Windows? If not, turn it off by following this guide and then try to mount your disk again. Oct 3, 2019 at 11:57
  • 1
    If windows fast-boot is on; the file-system will be in an inconsistent state (and thus being seen as unknown should not be unexpected) as part of the data for it is in the fast-boot (hibernate) save. It'll be recognized when that fast-boot.hibernate file is loaded, ie. in windows but in other OSes only after fastboot is disabled (and the data is actually written to disk partition fully).
    – guiverc
    Oct 3, 2019 at 12:02
  • Thanks for the quick answers, I'll check later at home if fast startup is turned on or not, and I'll report back.
    – Kriptonboy
    Oct 3, 2019 at 12:16
  • I just checked and Windows fast boot is already off, so the problem persists... any other idea?
    – Kriptonboy
    Oct 3, 2019 at 16:42
  • @Kriptonboy, we need a little diagnostic. Please right-click on your Start icon at bottom left, then choose Disk Management. Take a screenshot, save it as a file, then upload it to imgur.com or some other open image hosting site. Come back here, click edit and paste the address to your picture into your question.
    – K7AAY
    Oct 3, 2019 at 19:00

1 Answer 1

0

Thanks all who tried to help, I ended up formating the drive and restoring the data from a backup with minor file loss. I've messed up pretty bad with the tools trying to recover the drive /partition.

Good news is that now it actually works on both OS (win10 & Ubuntu)

Thanks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .