3

I am having issues with snaps. I first noticed this because anbox, a snap I had installed and used previously, stopped launching, so I then tried reinstalling upon which I would receive the following:

error: cannot perform the following tasks:
- Run install hook of "anbox" snap if present (run hook "install": cannot locate base snap core: No such file or directory)

I know core is a snap that should already be installed, so I did a snap list and got the following:

enter image description here

Just to see if it was specific to anbox or an issue with snaps, in general, I tried installing the hello-world snap and got the following:

$ sudo snap install hello-world
[sudo] password for zany130: 
hello-world 6.4 from Canonical✓ installed

 hello-world

cannot locate base snap core: No such file or directory

So no snaps are working on my Ubuntu machine. I also tried installing a snap through the Software Center, again it would install but not run. Do you have any ideas about what to do next?

  • You might try forum.snapcraft.io for snap related questions. However, it looks like this problem is affecting more than just snaps. At the top of your screenshot it shows the same error coming from bash "no such file or directory". Could it be a hard drive failure? something similar? – Ryan J. Yoder Oct 2 '19 at 16:42
  • oh thats because I setup bash to run this script and I have it named wrong and I been too lazy to fix. fixed it now it and that error is gone but I still get the snap errors. Thanks for the suggestion to post on the forms I try that as well – zany130 Oct 2 '19 at 18:51
  • You could try reinstalling snapd to fix this by running sudo apt install --reinstall snapd in the terminal. After that see if it is fixed or you can also run sudo snap install snapd in the terminal as it is missing from your snap list in the screenshot you posted. Best of luck – Raffa Oct 2 '19 at 22:18
2

This is happening with 'snapshot' or 'daily' images, or images that for some other reason had a broken seed.yaml (the file that helps snapd figure out what snaps to pre-load when you install the system).

We're working on fixing the issue at the image-creation level, but it's got a reasonably straightforward workaround:

sudo apt purge snapd && sudo apt install snapd

this works because purging will remove the broken seed.yaml, and reinstalling won't bring it back. You will however not have any pre-loaded snaps so if you notice you're missing something you expect to have (like maybe gnome calculator, say), that'll be why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.