0

I did a fresh install of Lubuntu desktop (meant as a headless machine mostly), with formatting the disk via installer.

Apparently it didn't create a partition properly.. no GPT but msdos.

The machine wouldn't boot to the main drive unless i unplugged the 2nd SATA drive (for storage). Remained stuck on HP bios.

The system is currently running, i have SSH access, but unfortunately won't be physically accessing the machine for a while.

After hours of crawling the web for tutorials and discussions.. no success. I've only managed to trash the fstab, and obviously didnt make backup (not that it was any good..)

here are a few cmd returns :
blkid

/dev/sda1: UUID="1124c007-a2cd-4e2b-8942-06fca94f5f88" TYPE="ext4" PARTUUID="4ac38d5d-01"

lsblk

   NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 596,2G  0 disk 
└─sda1   8:1    0 596,2G  0 part /

df

    Filesystem     1K-blocks    Used Available Use% Mounted on
udev             1959572       0   1959572   0% /dev
tmpfs             403696    1220    402476   1% /run
/dev/sda1      614267120 5072576 577921748   1% /
tmpfs            2018476       0   2018476   0% /dev/shm
tmpfs               5120       4      5116   1% /run/lock
tmpfs            2018476       0   2018476   0% /sys/fs/cgroup
tmpfs             403692       4    403688   1% /run/user/1000
tmpfs             403692       0    403692   0% /run/user/117

sudo parted -l

Model: ATA WDC WD6400BEVT-8 (scsi)
Disk /dev/sda: 640GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  640GB  640GB  primary  ext4

swapon -s returns nothing

How do i properly create a SWAP file with the current config (do i need one, how come the installer didn't make it?)

And most importantly what should the fstab look like please? So i can safely reboot the machine via SSH without fear of it not booting where it needs to and then the machine staying idle for weeks..

Thanks in advance !

(what will i need to run to be safe, regarding GRUB or else?)

ps: after install i had the following error (fwiw)

cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries nor crypto modules. If that's on purpose, you may want to uninstall the 'crypsetup-initramfs' package in order to disable the cryptsetup initramfs integration and avoid this warning.

.. removed cryptsetup and then ran update-initramfs -u

  • I'm confused by the part about booting and unplugging the 2nd drive. If you want partitions on that drive incorporated into the fstab, please provide info about them. No swap partition is the norm now, a swap file is used. (Assuming you are installing 18.04 or higher, you don't say). I also don't understand what you mean about gpt vs msdos, or what encryrption has to do with your situation. Details please. – Organic Marble Oct 2 at 11:27
  • Yes its 19.04 sorry forgot to mention. I do want to eventually use the 2nd drive for data only but currently more concerned about properly mounting the main one . I did find swapiness (retunred 60), does that need to be specified in fstab? Concerning MSDOS, i'm just confused as to why the installed didn't go for GPT when the hardrive is capable. the encryption thing just as fwiw. What's for sure is that the OS won't drive unless i manually unplug the other SATA, which only has data and wasn't plugged during install. – I'm a TI calculator Oct 2 at 11:35
  • 1
    Ok, thanks. I guess your current fstab is trashed so no point in adding it to the question? I will put together an fstab for you in a little while, when I get on a real pc. – Organic Marble Oct 2 at 11:38
  • yes it's beyond repair, pretty sure it won't boot again if i shut it as is. Concerning swap, if swapiness is on, shouldn't there be an alloted space and not Swap: 0B 0B 0B ? Thanks for the help :) – I'm a TI calculator Oct 2 at 11:42
  • does that loook viable to you for fstab ? # <file system> <mount point> <type> <options> <dump> <pass> # /dev/sda1 UUID=1124c007-a2cd-4e2b-8942-06fca94f5f88 / ext4 rw,relatime 0 1 – I'm a TI calculator Oct 2 at 11:58
2

I just created a 19.04 Lubuntu virtual machine. Based on its fstab it looks like you need a single line like this:

UUID=1124c007-a2cd-4e2b-8942-06fca94f5f88 / ext4 defaults 0 1

Don't include that device info /dev/sda1

  • worked great thank you, also had to go into BIOS and disable "fastboot" to prevent it from skipping stuff, many thanks ! – I'm a TI calculator Oct 2 at 12:46
  • I'm glad it worked for you. – Organic Marble Oct 2 at 12:46
  • 1
    If you want to mount a partition on the 2nd drive, use it's UUID and add a line like UUID=[its-UUID] [mountpoint] ext4 defaults 0 2 Before rebooting, try it with a sudo mount -a – Organic Marble Oct 2 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.