0

This is not duplicate of Ubuntu 18.04 Static IP with NetPlan require reboot I tried with both renderers with no lack. Changes are applied only after reboot. I tried ifup/ifdown/netplan apply. Nothing works. Fresh installation of Ubuntu 18.04 LTS on physical hardware. network-manager was not installed by default. I installed to test both renderers. I changed settings and used networkd as renderer. Changed again and used NetworkManager as renderer. After reboot latest changes are applied. Server has 2 raid controllers and it takes looong to reboot. According to documentation reboot is not needed. Any clue?

  • Have you tried sudo ifconfig <old name> down then sudo ip link set <old name> name <new name> then sudo ifconfig <new name> up? If that works, then you make the change to your /etc/netplan/01-netcfg.yaml to match. See: serverfault.com/questions/910406/… – Terrance Oct 1 at 14:32
  • Is this a desktop or server installation? Did you manually install NetworkManager? Is your problem a interface name problem as the title suggests, or a netplan reboot problem, as the body suggests? Some netplan changes DO require a reboot. – heynnema Oct 1 at 15:55
  • This is server. If I specified renderer: NetworkManager, after netplan apply I got error NetworkManager service not found. I checked, it was not installed by default (I installed minimal server). I installed network-manager (sudo apt install network-manager) and after it, I could use both renderers. To test further, I created 2 config files in netplan folder. One uses networkd as renderer and second uses NetworkManager. I changed names of adapters in both config files. netplan apply did not affect it. After reboot, both changes are in effect. – zdenko.s Oct 2 at 7:09
  • @Terrance This works. I am configuring different things and setting 4 NICS. If I have to do it in two different ways (one which works immediately and another after reboot), I am going to mess. I like netplan idea of yaml file. I can see all settings at once. – zdenko.s Oct 2 at 7:17
  • My next step was to add bridge. I installed bridge-utils, added bridge to netplan config, run netplan apply and changes were visible immediately???? Bridge state was DOWN. I restarted server and got errors when bringing network up – zdenko.s Oct 2 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.