0

I have tried every conceivable way of installing R on this server and it will not work all I get is the below error. I realize this has been posted a few times but none of the approved answers work for me. I'm new to ubuntu so please help. This is very frustrating.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
r-base : Depends: r-base-core (>= 3.6.1-3bionic) but it is not going to be installed
      Depends: r-recommended (= 3.6.1-3bionic) but it is not going to be installed
      Recommends: r-base-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I then tried to manually install r-base-core and got

Reading package lists... Done  
Building dependency tree         
Reading state information... Done  

Some packages could not be installed. This may mean that you have requested an 
impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.  
r-base-core : Depends: libc6 (>= 2.27) but 2.23-0ubuntu11 is to be 
               installed  
               Depends: libcurl4 (>= 7.28.0) but it is not installable  
               Depends: libicu60 (>= 60.1-1~) but it is not installable  
               Depends: libreadline7 (>= 6.0) but it is not installable  
               Recommends: r-base-dev but it is not going to be installed  
E: Unable to correct problems, you have held broken packages.

I then tried tried to install libcurl4 and got

Package libcurl4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source.

The other packages produce identical errors.

Again please keep it in layman's terms I'm well out of my depth.

10
  • Possible duplicate of Apt unmet dependencies while installing R on Ubuntu 16.04
    – Paharet
    Oct 1, 2019 at 2:50
  • Please look this answer here. Try sudo apt -f install then sudo apt-get install libc6 libcurl4 libicu60-dev libreadline7. It solved my issue on 16.04 when it failed to download certain packages.
    – Paharet
    Oct 1, 2019 at 2:52
  • This did not solve the problem as it now says libcurl has no installation candidate and is not available but referred to by another package. @Paharet Oct 1, 2019 at 2:59
  • There is no "layman's terms" for package management. You do it properly, or you break your system...which looks like what you did. Simply: Avoid non-Ubuntu software when possible. Always install versions of non-Ubuntu software that are compatible with your release of Ubuntu. Keep notes of EVERYTHING you install, including when, how, and why you installed it, where the packages came from, and how to uninstall it someday (you WILL need that). Learn how to use apt-cache policy and apt-cache madison and how updates are pushed into newer releases of Ubuntu (not older releases).
    – user535733
    Oct 1, 2019 at 3:34
  • The output looks like a classic new-user mistake. Easy to fix, though tedious. Start by uninstalling all non-Ubuntu, PPA, and wrong-version packages that you have installed on the system. If possible, start with newer packages and work backward - that way you remove less. Eventually, you will remove the package(s) with the wrong-version dependencies that are causing the problem. Then you can install whatever you like (except, of course, the wrong-version packages).
    – user535733
    Oct 1, 2019 at 3:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.