16

I have both Windows Terminal and Ubuntu installed from the Microsoft Store inside of Windows 10 (I don't know if this is WSL Version 1 or Version 2. The wsl -l -v command failed.).

My default directory is set to the right directory but it always opens up to root. How can I fix this config?

enter image description here

4
  • In Powershell wsl -l works, but the -v breaks the command and output from wsl -h is returned. The commands from the link you posted did not work either. I edited my post yesterday but this question appears to be dead. What can I do to improve it?
    – Jake Nixon
    Oct 1, 2019 at 18:48
  • 1
    See scotch.io/bar-talk/…
    – K7AAY
    Oct 1, 2019 at 18:52
  • @K7AAY -v doesn't work in WSL1
    – Kulfy
    Oct 2, 2019 at 11:08
  • Aha! A clew has been found!
    – K7AAY
    Oct 2, 2019 at 17:41

3 Answers 3

18

This is an issue raised on Microsoft Terminal's GitHub Page in Windows Terminal as startingDirectory setting issue for wsl profile #592 . And not respecting things is a hobby of some things.

Actually it seems that startingDirectory Windows Terminal doesn't work well under WSL fs paths since the issue isn't specific to $HOME, it exists for all folders in /.

While the user3140225's approach is a good start but as per DHowett-MSFT's comment:

This is also a great way to get weird and unexpected behaviour in everything else that uses bash on your machine. 😄

Since in Ubuntu's profile you've provided the command line wsl.exe -d Ubuntu. This command line invokes WSL and ask it to start "Ubuntu" which is done in the current directory, i.e. if you run wsl.exe -d Ubuntu while in Desktop of Windows, Ubuntu will start on Windows' Desktop.

As a workaround, you can modify the command line and use one of the below.

  1. Since WSL is specifically for Linux, thus Tilde Expansion can be expected from that. Therefore, you can specify the "starting directory" in the command line and use the following as the value of command line.

    wsl.exe ~ -d ubuntu
    
  2. When Ubuntu app is installed, it automatically registers ubuntu command. Therefore, ubuntu command will invoke Ubuntu App. The benefit of this is that it always starts at $HOME. Therefore, you can change the value of command-line to

    ubuntu
    

    Note: If you are using Ubuntu 18.04 or 16.04 app, the command would vary accordingly. The above is only for Ubuntu App.

  3. If you're uncomfortable in changing command-line, you can still get it to work by modifying startDirectory to

    "startingDirectory":"//wsl$/Ubuntu/home/jake/"
    

    Credits: caksoylar 's comment

1
  • 1
    Thanks for all of this information, including the page about Tilde Expansion. I changed the JSON configuration inside of Windows Terminal to add the ~ to wsl.exe -d ubuntu and my problem is solved. I deleted the cd ~ from my .bashrc file to avoid any strange behavior from other bash utilities. Thanks very much!
    – Jake Nixon
    Oct 3, 2019 at 23:21
8

You can do the following:

  1. Open WSL and edit your ~/.bashrc file using nano:

    nano ~/.bashrc
    
  2. At the bottom of the file add the following line:

    cd ~
    
  3. Save and close the file by pressing Ctrl+O followed by Ctrl+X.

  4. Finally, restart WSL.

2
  • 5
    In one line: echo 'cd ~' >>~/.bashrc
    – dessert
    Oct 12, 2019 at 5:33
  • 1
    I would like to verify that @user3140225 provided the most streamlined answer to this question. No permutation of changing the "startingDirectory" value in the Windows Terminal settings.json correctly navigated me to the correct home directory you would get when launching WSL in its own shell. It seems that the configuration file does not accept Linux syntax as arguments. Adding cd ~ to your .bashrc file from within Ubuntu was the easiest and best option at this point, with @dessert providing the quickest means to do so in one line from $HOME directory: echo 'cd ~' >>~/.bashrc Sep 1, 2020 at 0:54
0

Seeing some answers in here, and knowing this is an old thread, I still wanted to respond to those stating to put "cd ~" in the .bashrc file. While that works, that means every interactive non-login shell reads .bashrc first. That means whether it's the first terminal opened, or every subsequent terminal/bash process is spawned from the initial "login" terminal, you will always end up in the home directory.

You can test this by editing .bashrc putting the "cd ~" command in it. Exit Windows terminal. Then launch Ubuntu again. You'll be in the home directory. Now, navigate to a different directory within that terminal session and then execute "bash". You'll end up in your home directory which might not be what you wanted.

This same issue happens if you are using Visual Studio code. In VSC, you have the ability to create terminal sessions. Many are expecting that session to open up in whatever directory they launched VSC from (mostly a project they are working on). However, that will execute the commands in .bashrc which means you'll end up in your home directory.

.bashrc is suited for commands that are specific to the Bash shells. So, putting aliases and other Bash related functions into .bashrc is good.

A better place to put the "cd ~" is in the .profile file. This way, upon the initial terminal bash launch, it will execute the "cd ~" command in .profile. If you then launch VSC from a different directory, when you create a terminal session within VSC, it will stay in the directory you launched VSC from which is what most programmers would expect.

After doing this and removing "cd ~" from .bashrc, launch a new terminal session. You'll be in your home directory. Then, navigate to a different directory and type "bash". You'll start a new bash session but stay in the directory you were last in.

If you launch a new Ubuntu terminal inside Windows Terminal, you'll be back in your home directory since it's a brand new Terminal login session.

Hope that helps!

1
  • Agreed, .profile is probably better than .bashrc, but both can create issues for the unsuspecting user (or script). Better yet to just use wsl ~ as in the accepted answer. Jul 29, 2021 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.