1

A few days ago, I opened an issue (that is still unaswered and might be related MSI GS65 Stealth Thin 8RE less than symbol printing ç symbol ) about the keyboard of my MSI laptop and the less-than < and great-than symbols > not working on it.

Sadly, I haven't figured out yet a way to resolve this. But just today, I've realized that the mark accents aren't working either.

Every time I press on the ´ or ` symbols, they get written immediately, without giving me the chance of pressing a vowel to write the acute versions of these vowels, I get the following:

  • ´a
  • ´e
  • ´i
  • ´o
  • ´u

There's definitely something wrong with my keyboard and the thing is that it worked perfectly fine after installing Ubuntu 18.04. But after I did a clean install of 19.04 I'm getting this keyboard problems.

Any help would be really appreciated :(

8
  • Not really, it has Spanish layout. I've tried setting it up to en-US or other layouts without any luck.
    – xarlymg89
    Sep 30 '19 at 8:57
  • Only if I set it up to Spanish, then the ç works great. Which is necessary for Catalan language and it's on Spanish layout.
    – xarlymg89
    Sep 30 '19 at 8:58
  • So right now the only thing, as far as you know, is to perform a temporary remap and wait for the definitive fix. Right?
    – xarlymg89
    Sep 30 '19 at 10:13
  • Let us continue this discussion in chat.
    – xarlymg89
    Sep 30 '19 at 10:32
  • Confirmed that except the less-than and great-than symbols, the mark accents are working fine on Ubuntu 19.04 live CD.
    – xarlymg89
    Sep 30 '19 at 11:22
1

Well, finally I've got to fix the keyboard layout about the mark accents matter at least.

I had applied a change in the ~/.profile file:

export GTK_IM_MODULE=xim
export XMODIFIERS=@im=xim

However, the previous values were:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus

I remember changing those values to try to fix the problem I still have with the less-than and great-than symbols not being printed as described in MSI GS65 Stealth Thin 8RE less than symbol printing ç symbol

So one problem solved, after messing things up ¬¬

1
  • If you still have a remote idea about what's the matter with my other problem, will appreciate it :)
    – xarlymg89
    Sep 30 '19 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.