5

Both my external speakers (via headphone jack) and monitor speakers (via displayport) worked prior to the update, though I remember having to fiddle when I first installed Ubuntu. Since the upgrade, the only sound output device that displays is a Unix FIFO sink from my chrome-remote-desktop.

I've tried everything the internet mentioned, but I can't seem to figure out what's wrong and I feel as though I've expended all of the old recommendations I've found here and elsewhere. As you'll see below, my sounds cards are present but somehow not being detected by the system/pavucontrol, so my best guess is there's some config file that's hanging out that I haven't been able to find and purge. Any suggestions are appreciated--I'm at my wits end and just want to watch Netflix... :)

My /proc/asound/cards has the following:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xef630000 irq 39
1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xef080000 irq 17

Likewise, lspci -v | grep -A5 -i "audio" says:

00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
    Subsystem: ASRock Incorporation 9 Series Chipset Family HD Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 39
    Memory at ef630000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
--
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] GP106 High Definition Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at ef080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

So I know my sound cards are there. I've also confirmed that nothing is muted in alsamixer.

aplay -l produces:

    **** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I've run pulseaudio -k && sudo alsa force-reload, as well.

I've tried uninstalling and reinstalling audio packages recommended here: Sound card stopped being detected

I've tried everything here, too: No sound in Ubuntu 18.04 LTS after upgrade from 16.04 LTS In pavucontrol no cards are detected so I can't unmute gnome-alsamixer.

I've added options snd-hda-intel model=auto to the end of my /etc/modprobe.d/alsa-base.conf also. I built my own computer and maybe there's something better than "auto"?

I tried removing snd_hda_intel with pulseaudio -k && sudo service alsa-utils stop && sudo modprobe -r snd_hda_intel && sudo modprobe snd-hda-intel && sudo service alsa-utils start && pulseaudio -D but couldn't because it was in use.

I'm out of ideas. :/

Edit

Here's the output of dmesg for "snd_hda_intel":

[    5.333219] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[    5.333703] snd_hda_intel 0000:01:00.1: Disabling MSI
[    5.333708] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    5.359714] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready 0x00000000

And for "audio":

    [    5.333708] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    5.359714] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready 0x00000000
[    5.360474] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1150: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[    5.360475] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.360476] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    5.360477] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    5.360477] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    5.360478] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    5.360479] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    5.360480] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    5.360481] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[    5.382505] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
--
[   35.360044] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 4
[   37.069091] rfkill: input handler disabled

And I ran the Ac instructions here: https://help.ubuntu.com/community/SoundTroubleshootingGuide

$ echo "Sound cards recognized by the system:"; lspci -nn | grep --color=none '\[04[80][13]\]'; echo "Sound cards recognized by ALSA:"; lspci -nn | grep '\[04[80][13]\]' | while read line; do lspci -nnk | grep -A 3 '\[04[80][13]\]' | grep -e 'Kernel modules: ..*' -e '\[04[80][13]\]' | grep --color=none -F "$line"; done; echo "Sound cards recognized by ALSA, and activated:"; lspci -nn | grep '\[04[80][13]\]' | while read line; do lspci -nnk | grep -A 3 '\[04[80][13]\]' | grep -e 'Kernel drivers in use: ..*' -e '\[04[80][13]\]' | grep --color=none -F "$line"; done
Sound cards recognized by the system:
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
Sound cards recognized by ALSA:
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
Sound cards recognized by ALSA, and activated:
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)

Edit 2

Here's the output of sudo fuser -v /dev/snd/*:

                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  gdm        1934 F.... pulseaudio
/dev/snd/controlC1:  gdm        1934 F.... pulseaudio
  • Please edit your post including the output of sudo fuser -v /dev/snd/* – abu-ahmed al-khatiri Oct 3 at 3:07
  • I've updated the post with the output as requested! – GenesRus Oct 4 at 2:25
  • @abu-ahmedal-khatiri, I added the output to the post. Could you help me interpret it? Sorry, I'm not sure how to tag you... askubuntu.com/users/856659/abu-ahmed-al-khatiri – GenesRus Oct 9 at 8:22
  • Did you edit any pulseaudio config files in /etc before the upgrade? – life-on-mars Oct 9 at 10:38
  • 1
    @GenesRus My first idea here would be that PA is the culprit. How config files are updated changes sometimes, so I wouldn't be so sure they are simply overwritten. Try with default settings. Otherwise, my next step would be if the problem persists when booting from a LiveCD. If audio works there, the simplest solution would be to backup /home and do a clean install. – life-on-mars Oct 10 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.