After loooong searches it seems that linux users are pretty much screwed when it comes to Optimus. Does anyone know of a workaround other than trying to flash the BIOS with the hack that will show an apparently "hidden" menu item (On Acer BIOS) to disable the Intel gfx in the BIOS? Or even better, does anyone have a flash program that will do that or some workaround?

Also the Intel interface is horrible. It does not allow me to choose my projector's correct resolution either with HDMI or VGA port (even though it picks up the correct model). To make matters worse, the HDMI outputs junk. The graphics are unwatchably dark and I have tried to set it, but the Intel interface is useless for that. It does the same in Windows mode (I dual boot) so I suspect it may just be the port itself that's screwy.

I am running bumblebee at the moment, but that's just for certain programs and does not allow me to do monitor configurations with the nvidia settings.

Can anyone point me to a useful place for an answer maybe? My eyes are already scratchy from searching over the past 2 days.


After lots of research it seems like the following applies(I upgrade to 12.04 Precise, but that shouldn't change things):

Bumblebee is a must to use the nvidia card. It works wonderfully. As a note you need to run PlayOnLinux for games with optirun!

I installed the nvidia drivers (using nvidia-current), but that seems to break my 3D Unity. Still investigating. The default Ubuntu display drivers correctly identified my projector, but not its resolutions.

The HDMI initially seemed broken with washed out colours and wrong resolution on my projector (which is a native 1280x768) and even the VGA output had wrong resolutions. I used xrandr to create a new mode and then add it to the HDMI and VGA output. See solutions on this here:Configuring xrandr for custom resolutions Then when connected you can set the new mode in the "displays" link from the top right power button.

AMAZINGLY this also solved the HDMI colour issue as well! I am now happy as I can use my multimedia laptop as I wanted to.

  • 1
    Bumblebee installs nvidia-current as dependency, if your 3D unity now breaks, try reinstalling bumblebee. If after a restart of X/reboot the issue persists, start wondering whether you are using the nvidia card now as primary graphics chip (considering that you mentioned an option to disable Intel in BIOS) – Lekensteyn May 18 '12 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.