2

I really want to dump my Windows 7 on my other computer, because Ubuntu is much better. But on that computer, I get no sound on Ubuntu but when it's on Windows, it works fine.

I have checked settings, it lists my onboard audio and that is what is selected, and turned on (not muted). I installed Ubuntu on this computer too without any problems.

On this computer (that has sound), I remember that I installed Ubuntu 14 and then updated to 18.04. I'd hate to have to do a complete reinstall on that other computer, so is there anyone who knows enough if that was the difference? This working one is a newer motherboard/cpu.

enter image description here

4
  • Try to install pavucontrol, maybe you need to configure something in "Configuration". – Jerare Oct 6 '19 at 14:22
  • 1
    What graphics card is driving the HDMI monitor with no sound? – WinEunuuchs2Unix Oct 6 '19 at 14:23
  • It's all onboard audio, video. But like I said Win7 plays it fine. I've looked at the "settings", I added the picture. and messed arouind with puvacontrol. I may just have to bite the bullet and reinstall version 14 and then upgrade like I did on this one. Does anyone think that makes any kind of sense? – P Simdars Oct 6 '19 at 19:19
  • Have you tried booting a liveUSB with Ubuntu 18.04 or maybe 19.10? – To Do Nov 18 '19 at 11:44
0

I finally tried what I had not wanted to do : removed 18.04. I then selected HDMI in the configuration and the sound was there.

So, I took all upgrades and it still worked. It asked to upgrade to version 16 and I did that and the HDMI sound still worked. Then I took all updates in 16 and it still worked.

Finally it asked me to upgrade to 18.04 and I took that too. But when I restarted with 18.04, there was that newer interface and the HDMI sound had stopped.

In previous versions, there was an HDMI option in audio settings that disappears on 18.04. Maybe there's some determined developers who wants to look at what they changed/removed between 16.04 and 18.04.

In configuration settings of 18.04, there is no longer the option for HDMI sound.

It took me 6 hours for upgrades to get up to date from 14 to 18 . . ugh! but I do really like Ubuntu.

3
  • so is your issue solved? – damadam Nov 18 '19 at 10:45
  • This is not an answer. You should have edited your question adding the extra information instead. – To Do Nov 18 '19 at 11:43
  • Sorry, I thought I'd answered it, but it didn't work. There is no HDMI sound for 18.04 – P Simdars Nov 18 '19 at 13:52
0

Here's what worked for me:

  • Open the Sound app
  • In the Hardware tab, find the "Profile" drop-down in section "Settings for the selected device"
  • There should be a number of HDMI options here (for me, a lot.)
  • Plug in your HDMI device (unplug it first if needed.) For me plugging in changed the drop down to a workable one. If this doesn't work just pick some.
  • Go to the Output tab, see a HDMI device selected
  • Try playing some sound

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.