1

I'm trying to make fcitx work under Lubuntu.

Here are problems I'm facing:

  • fcitx is not auto-started with Lubuntu. I checked the lxsession auto-start configuration, and found that fcitx is not an option there.
  • I can launch the fcitx applet from the menu with System Tools ‣ Fcitx, but that has two more problems,
    • I still cannot turn my google pinyin input on using keyboard
    • If I turn my google pinyin on using its pop-up menu, it will freeze the whole system. Tried and verified many time when using the leafpad, and even the fcitx configuration program itself -- start leafpad or fcitx configuration program, then left click Fcitx icon trying to bring up its pop-up menu, the whole system will freeze.

This is Lubuntu 18.04.02. I am able to make fcitx work under Mate 18.04, so I think it is a Lubuntu specific problem.

Is there a solution?

1 Answer 1

0

Following the simple steps in https://www.jianshu.com/p/c936a8a2180e solved all above problem.

Just that my sogoupinyin is crashing all the time. but that's a different story. At least, now my google pinyin input is working.

Again, to summarize, I installed fcitx-googlepinyin previously, and apparently there are some missing dependent packages (in its dependent list). The sogoupinyin package force installed the following packages, which solved the above problems:

The following NEW packages will be installed:
  fcitx-frontend-qt4 fcitx-libs fcitx-module-kimpanel libaudio2 libfcitx-qt0
  libmng2 libopencc2 libopencc2-data libqt4-dbus libqt4-declarative
  libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libqtwebkit4 qdbus
  qtchooser qtcore4-l10n

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .