1

Updated Description: I'm struggling with getting a dual-boot HP Pavilion to boot directly into Grub. I've set up several dual-boot systems in the past wthout difficulty, but this one seems to be different. The only difference I'm aware of is that in the past I've either worked with a preinstalled Windows or wiped the disk entirely before proceeding, This time I wiped the preinstalled Windows and then installed Kubuntu, thinking I didn't really need Windows on this machine at all. I later changed my mind and installed Kubuntu; I didn't remove the old HP recovery partition or the EFI partion.

If I power up and immediately press Esc, I get a screen containing the following:

Boot Options Menu

OS Boot Manager
Ubuntu (WDC WD10JPVX/22JC310)
Boot From EFI File
Notebook Hard Drive

This menu does not offer any way to change the order of the items. I can get into Grub from here, but that's an unsatisfactory solution since it requires intervention on every reboot. Unsurprisingly,the boot options in the BIOS Setup specify only devices and provide no way of selecting a particular partition. Those options are:

USB Hard Disk
OS Boot Manager
Internal CD/DVD Drive
USB CD/DVD ROM Drive
Network Adapter

I don't know if "OS Boot Manager" has to be the Windows boot manager or if any boot manager (like grub) that's in the right place will do.

So far my attempts to do grub-install /dev/sda have no effect on this behavior, and the fact that the Boot Options Menu already contains Ubuntu suggests that grub-install by itself is not sufficient. Boot-Repair does not help.

fdisk /dev/sda produces:

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: DCAAF5C5-5710-44E2-8CDB-61C8C51B0A78


Device          Start        End    Sectors   Size Type
/dev/sda1        2048     534527     532480   260M EFI System
/dev/sda2      534528     567295      32768    16M Microsoft reserved
/dev/sda3      567296 1107322879 1106755584 527.8G Microsoft basic data
/dev/sda4  1926522880 1928529919    2007040   980M Windows recovery environment
/dev/sda5  1928529920 1953511423   24981504  11.9G Microsoft basic data
/dev/sda6  1107322880 1693259775  585936896 279.4G Linux filesystem
/dev/sda7  1693259776 1699119103    5859328   2.8G Linux swap

As expected, sda5 contains Windows and sda6 contains Kubuntu.

I've tried two different remedies, one Linux-based and one Windows-based. Under Linux Ive used efibootmanager to reorder the boot sequence. It seems to do the right thing, but the effect is lost on rebooting. In Windows I've used bcdedit, which again seemed to work but didn't survive a reboot.

I've also presented my problem in a thread "Rearranging boot partitions", which I'd like to combine with this one, but I don't know how to do that.

Further Update: I solved my problem by repartitioning the disk to clean it, then installing Windows followed by Kubuntu. I now boot directly into Kubuntu, with a menu item taking me to Windows so I never need the Boot Options menu ( brought up by F9). But out of curiosity I brought it up anyway, with an interesting result:

OS Boot Manager
Ubuntu
OS Boot Manager
Notebook Hard Drive
  • 1
    I think you need to get into what was called the bios and set the default for what to boot at power on. You shouldn’t need to press Esc. I’d guess that would be “Boot from EFI” to get grub. Would be worth updating the question with what boots when you don’t press Esc and what happens when you choose each option from that boot options menu. In many instances you just change the order of a list quite like your boot options list. I assume everything is installed in UEFI mode? – PonJar Sep 26 '19 at 22:12
  • Did you got any solution? I am looking for one as well :) – Animesh Sahu Jun 4 at 12:10
1

have you tried setting grub as the boot manager for Windows do this in windows cmd prompt:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

| improve this answer | |
  • 1
    I tried that (literally() and it had no effect, Could some part of that command need to be modified? – Paul A. Sep 26 '19 at 23:16
  • no have you tryed running cmd prompt as administrator? – wraith3690 001 Sep 28 '19 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.