0

Fitted an Addon AWP1200E 5Ghz WiFi card today which depends on Linux drivers from files in /drivers/linux/AWP1200E_linux.zip/RTL8812AE_Linux_v4.3.2_12208.20140904/ extracted from http://www.addon-tech.com/new_/down/upload/20150812/1439396363.zip .

On my 74mb connection I only get about 37 mb/sec; hardwired I get about 67 mb/sec and on my Windows PC I used to get over 70mb/sec with WiFi.

Why is it slower on Ubuntu? How can I get this card to deliver the speed I got with Windows? Here's what lspci -knn | grep Net -A3 && rfkill list shows:

05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter [10ec:8812] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter [10ec:8812]
    Kernel driver in use: rtl8821ae
    Kernel modules: rtl8821ae
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
  • 1
    How do i enable full duplex ? I did some reading and think this is my problem – venomx Sep 26 '19 at 20:29
  • 1
    Done that thanks – venomx Sep 26 '19 at 20:41
  • 1
    @venomx Did you run the command lspci -knn | grep Net -A3 && rfkill list if so, edit your question and paste the output of the command into your question. – mchid Sep 26 '19 at 20:44
  • 1
    Yes dude ive just done that – venomx Sep 26 '19 at 20:47
  • 2
    Possible duplicate of RTL8812AE WiFi card driver install fails – heynnema Sep 27 '19 at 0:30
0

I struggled with the same issue for days (had 6 Mb/s on my Ubuntu 18.04) Downloaded that driver from github and now I finally have my network running at 144Mb/s:

https://github.com/mid-kid/r8822be

I'm a total noob so if any other noob out there has this issue that I had, and specifically those that want to kill themselves after buying Lenovo Legion Y530 and thought it will be a walk in a park installing Ubuntu 18.04...

  1. Download as a zip the whole git from the link above

  2. Rename the old driver file (it's possible that the kernel version had changed by the time you're reading this):

In one terminal (let's call this one term1):

cd /lib/modules/5.0.0-29-generic/kernel/drivers/staging/rtlwifi

sudo mv r8822be.ko r8822be_.ko

ll

(you should see that the file name had been changed successfully)

  1. Extract the zip somewhere (I have a folder that contains some other drivers that I tried, including some of the TP-LINK dongles I bought, none really worked of course...)

  2. In another terminal (to be called term2), go to the unzipped folder (where the readme file is) and follow the readme file instructions. For me, I did it like so:

./make

sudo ./make install

  1. Now back to term1, ll again to check if it wrote the file. Hopefully it did.

  2. Reboot.

Hope it works for you!

If it did, I think you can remove the r8822be_.ko now (I made a copy just in case)

If anyone has comments I would love to read them

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.