1

I have installed Ubuntu 18.04 alongside Windows on my new ASUS Zenbook 13 UX333F and have had many issues. Most noticeable is that when the grub screen loads and I select Ubuntu, sometimes the grub text disappears and nothing else happens. I have tried waiting for a long time but literally nothing happens, no error text is shown either.

The first time I noticed this I was the first time I had powered off my laptop since installing Ubuntu (after setting up everything..) and I thought something was broken so I reinstalled it (set everything up again..) and it happened again. However, I tried restarting my laptop multiple times and suddenly after the 5th time it showed some terminal text and then worked!

Since then, every time I power off my laptop I have to try booting Ubuntu, wait and see nothing happen, restart and try again a seemingly random number of times (between 0 and 15) until finally it works. I managed to capture the error text in two pictures, I think it is the same every time. I hope someone can tell me how to fix this.

It might be worth mentioning that I have some other problems with Ubuntu on this laptop that I never had with my old ASUS:

  • My sound did not work at all, neither headphones nor speakers. I fixed this by upgrading to Kernel 5.0.8 via the ukuu command-line tool.

  • It does not hibernate or even sleep, I have followed a number of instructions to fix this but nothing seems to work. The battery drains really fast while the lid is closed.

I have reinstalled Ubuntu 18.04 multiple times (also tried 19.05), updated the kernel to multiple versions and nothing helped.

Why can't I have a smooth, stress-free Ubuntu experience on this new laptop?

0

have you tried updating your motherboard bios to the latest version? I ask this because the first pic has "acpi bios error(bug)" here is a link to ASUS site where you can dl it https://www.asus.com/Laptops/ASUS-ZenBook-13-UX333FA/HelpDesk_Download/

  • Now it doesn't load Kernel 5.0.8, but 5.0.0 works perfectly! Thank you (sorry for the delayed reply). – dashdeckers Oct 5 '19 at 9:30
  • However, I think Kernel 5.0.8 was important for the sound to work because when I tried to play a video after booting 5.0.0, it had a weird 'tinny' sound to it before dying out completely. – dashdeckers Oct 5 '19 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.