4

I'm a noob. Putting this out there right away. Using Lubuntu 19

I want a blue light filter. So I've installed f.lux, but when I adjusted the brightness on my laptop it toggles or flashes between the screen without f.lux and then back to f.lux as I increased or lowered brightness. So I uninstalled f.lux and reinstalled it. Now it doesn't work at all.

As for Redshift, when I change the brightness it automatically just switches back to the brightness level that redshift has assigned. This is quite different then how it acts on other operating systems where you can lower or increase the brightness yet keep the effect of redshift--which is all I want. Can anyone help, or should I just install Ubuntu?

  • I use redshift on my Lubuntu without issue; and use the same config file that was setup for 17.10 (and works on fine on standard Ubuntu, debian & other places I've tried to), thus I suspect your redshift.conf file could be setup incorrect. Myself, I just followed help.ubuntu.com/community/Redshift and used a search engine to find my latitude/longtitude, temperature settings I just played with until I was happy. (ps: I'm now on 19.10; but it works on 19.04/18.10/18.04 & 17.10, 16.04 & 14.04) Note: the only time I've had probs was it was running twice on the system; use ps to check – guiverc Sep 26 '19 at 5:19
  • I just realized the issues arises when I change brightness using the keyboard. But not when I use the brightness meter in brightness settings. Can anyone help with this? – Vinnie Ross Sep 26 '19 at 5:24
  • Does this command work for you ? xrandr --output eDP-1-1 --gamma 0.9:0.7:0.7 (Replace the eDP-1-1 with the output of this command xrandr | grep -i primary | awk ' { print $1 }' ) – Parsa Mousavi Jun 25 at 21:33
  • I have Ubuntu 20.04 and it comes with a night option, just in display settings. You can set up the start and end time, or automate it (from sunset till sunrise). It is not gradual, as f.lux, but it does the job and you can adjust how warm you want the screen. I'd be surprised if you can't have that setting in Lubuntu... Maybe you have it and that's why you have a conflict with f.lux? – Nandete82 Jun 29 at 14:48
1

If redshift or f.lux don't do what you want you can try:

  • Night Light (for Ubuntu versions 18.04 and 20.04). This may have the same problem.
  • eyesome (for all Ubuntu versions 16.04+ not using Wayland). Supports three monitors independently and probably does what you want.

Disclaimer: I wrote eyesome.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.