3

I just installed Ubuntu 18.04.3 and found the two-finger scrolling way too fast. So I followed the instructions in this thread and ran

sudo apt install xserver-xorg-input-synaptics

But that required xserver-xorg-core, so I installed that as well. I rebooted and, once X started, I had no keyboard, but the mouse was working.

So I found this thread and it seemed very similar to my case. However, my grub menu boot allowed only for a recovery boot with no internet access. So, while I could remove the xserver-xorg-input-synaptics, I had no way to reinstall the ubuntu-desktop and xserver-xorg.

I could still boot the machine, but maybe due to the above inability to reinstall, as soon as I logged in in X, I was thrown out again, to the login screen.

The second thread mentioned that ownership of ~/.Xauthority in my home folder could be the reason, but I had no such file!

In the end, I had to reinstall from the ISO – no big deal as it was a new install. I still have no ~/.Xauthority in my home folder. And now I'm quite hesitant to install input drivers – without any way to ssh into my machine, I'm helpless without a keyboard!

2
  • If you "just installed" it, wouldn't it be easier and faster to re-install on this case and go about solving the scrolling issue via built-in settings or some other method, if possible? – code_dredd Sep 25 '19 at 21:31
  • The built-in settings that Ubuntu comes with lets me choose the speed of the touchpad cursor, and lets me turn the two-finger scrolling on or off. However, it does not let me choose the scrolling speed. Hence why I tried the solution mentioned above. – Zimeon Sep 26 '19 at 8:26
1

What worked for me was completely removing xserver-xorg-input-synaptics

  1. Activate the on-screen keyboard (Settings => Universal Access => Screen Keyboard)

  2. Removing xserver-xorg-input-synaptics

    sudo apt remove xserver-xorg-input-synaptics
    
  3. Installing xserver-xorg-input-all

    sudo apt update
    sudo apt install xserver-xorg-input-all
    sudo apt ugrade
    
  4. Restarting my system

    reboot
    
2
  • That would have worked if I'd known to activate on-screen keyboard to remove xserver-xorg-input-synaptics But since I did that from a regular terminal, I was from there unable to log into X – I was just thrown out. And the grub terminal had no internet access, so I couldn't install anything. – Zimeon Feb 16 '20 at 8:27
  • This worked for me but luckily I did not have to uninstall xserver-xorg-input-synaptics since this driver is necessary to use the touchpad on my lenovo – mjabei Sep 14 '20 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.