0

Im following this tutorial https://help.ubuntu.com/lts/serverguide/certificates-and-security.html#creating-a-self-signed-certificate this works fine in ubuntu 18 but not in ubuntu-core 18.

Im trying to create a CA to sign certs for etcd cluster but receive error cannot create directory read only file system.

user@core-1:~$ sudo mkdir /etc/ssl/CA
mkdir: cannot create directory ‘/etc/ssl/CA’: Read-only file system

Question: Where should the CA be created or how should it be created ?

0

Linux marks a filesystem as read-only when it discovers errors in the filesystem during mounting.

  • Run Ubuntu Live CD and performed a disk check from there

If the error still persist, you can proceeded with the following solution:

  • Reboot and select the "recovery mode" kernel from the grub menu. (If you don't see this menu, hold down shift during boot.) You'll end up at a menu; choose the "root shell" option.

Now it's time to cut-and-paste

mount -n -o remount,rw / 
touch /forcefsck
shutdown -r now
  • This is Ubuntu Core OS, Ubuntu Core is a lean, strictly confined and fully transactional operating system. We designed it from the ground up, to focus on security and simplified maintenance, for appliances and large device networks. Ubuntu Core is powered by snaps - the universal Linux packaging format. ubuntu.com/core – m0ng00se Sep 25 at 14:26
  • Your solution doesn't work on Ubuntu core. – m0ng00se Sep 25 at 14:27
0

Creating CA in etc/ssl is not yet possible in ubuntu-core, its possible at the app level, not system level. This link from snapcraft forum explains https://forum.snapcraft.io/t/extending-system-certificates/114

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.