2

(Kubuntu 18.04, KDE Plasma 5.12.9)

I'd like to try Krusader in place of Dolphin and would like to continue using Meta+E as the keyboard shortcut. After installing Krusader, I did the following:

  1. I opened System Settings from the application menu.

  2. I looked under the Workspace heading, clicked Shortcuts -> Global Shortcuts -> KDE Daemon and found the entry File Manager: Meta+E. I made no changes here.

  3. Back in the main window of System Settings, under the Personalization heading I went into Applications -> Default Applications -> File Manager.

  4. I selected the radio button Other: click Add... in the dialog shown here and clicked the ... button next to it.

  5. I was presented a dialog box entitled Edit File Type inode/directory -- File Type Editor. In the lower panel entitled Application Preference Order I clicked the Add button.

  6. I was presented a dialog box entitled Choose Application for inode/directory -- File Type Editor with the a tree listing of application categories found in my application launcher. I selected Utilities -> Krusader, which added Krusader at the top of the list of applications in the Application Preference Order panel.

  7. I clicked OK, there was a dialog box that gave an indication that something was being updated. When done, in the File Manager -> Default Component list I selected Krusader and clicked Apply.

  8. As it was in the KDE Daemon category, not knowing how to restart a daemon without rebooting the computer, I went ahead and rebooted.

Unfortunately, Meta+E is still bringing up Dolphin. I did discover, though, when right-clicking an empty spot on the desktop, the context menu has an entry, Open with Krusader Alt+D,T which does work. I don't know where this shortcut is defined. I can use that in a pinch, but would prefer Meta+E. Any suggestions?

Global Shortcuts -> System Settings KInfocentre

  • Apologies for the backticks. plasmashell -v gives "5.12.9" and dolphin -v gives "17.12.3". – granti128 Sep 25 '19 at 3:53
  • That's what I have too. But I don't see the Meta+E shortcut. AFAICT, it's not available in Kubuntu 18.04. See phabricator.kde.org/D19831 – DK Bose Sep 25 '19 at 3:55
  • Very strange indeed. I assure you though, that "Meta+E" does launch Dolphin. Oddly, I've just brought "System Settings" back up, and the "File Manager" shortcut has migrated from "KDE Daemon" to "System Settings", and is still set for "Meta+E". On my system, "Meta" refers to the MS logo key. – granti128 Sep 25 '19 at 4:05
  • 1
    Screenshot added to post – granti128 Sep 25 '19 at 4:20
  • 1
    Screenshot added to post. – granti128 Sep 25 '19 at 4:38
2

Note: this answer is speculative because I don't see the Meta+E shortcut to launch the file manager on my Kubuntu 18.04!


  • Open System Settings > Shortcuts > Custom Shortcuts
  • Click on Edit > New > Global Shortcut > Command/URL
  • In the interface that appears,
    • for the Comment enter a suitable description,
    • for the Action, enter krusader,
    • for the Trigger, in the box next to Shortcut click on None which will change to Input,
    • press Meta+E.
    • You'll probably get a beep and a window will appear to warn you that Meta+E conflicts with the shortcut assigned to File Manager.
    • Click on Reassign to override the existing setting thereby setting Meta+E to launch Krusader.
    • Click Apply.

From now on, Meta+E will launch Krusader.


Re.

… I did discover, though, when right-clicking an empty spot on the desktop, the context menu has an entry, Open with Krusader Alt+D,T which does work. I don't know where this shortcut is defined. …

In Kubuntu 18.04 or 19.04, right-clicking on the desktop pops up a context menu with one option being Configure Desktop. Choosing that opens a new window. Select mouse actions on the left and then, next to the dropdown for Right button there's a settings icon. Clicking on that has the Alt+D,T setting (among others). For me, on both systems, it's already there and set to Open with Dolphin by default. In your case, it reflects your preference for Krusader.

The image below is from Kubuntu 19.04 with Plasma 5.16.5 and so the icons aren't the same as those in Kubuntu 18.04:

Standard menu options

  • Thanks! Any idea where the original "Alt+D,T" was set? I certainly didn't set it myself. – granti128 Sep 26 '19 at 22:23
  • I have edited the answer to cover the Alt+D,T aspect. – DK Bose Sep 27 '19 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.