I just built a new system with MSI 5700 Gaming Edge Wifi motherboard (with click bios), Ryzen 7 CPU and Radeon 5 GPU and Samsung M.2 SSD.

I made a bootable Ubuntu image with UNetbootin and confirmed that it works fine on my current computer. When I try to boot from it on the new system I initially get the error:

Couldn't get size: 0x800000000000000e
MODSIGN: Couldn't get UEFI db list
Couldn't get size: 0x800000000000000e

and then it gets stuck in the purple Ubuntu loading screen forever.

When I edit the GRUB entry and remove quiet splash and add nomodest I get the following scroll of messages (it goes way off the page but scrolls faster than I can read).

boot log

I'm assuming this is all caused by one problem (blocked by a certain hardware thing?) but I have no idea what it is or how to find out. I followed all the solutions I could find for the "UEFI db list" error and nothing helped. I have secure boot disabled (it was disabled by default). I tried switching between UEFI and CSM but that didn't change it.

What are the next steps I can take to diagnose this? Or does anyone have a guess what could be the issue?

  • 3
    What version of Ubuntu are you attempting to run? Have you checked for any bios updates for that motherboard? – Gordster Sep 24 '19 at 17:49
  • 3
    I tried 2 different USB drives and two different copies of the ISO, but it boots fine on my laptop so I don't think the installation media is bad. This also happens whether I pick install or try without installing, with or without safe graphics, and it happens whether I boot from the partition or the whole device – B1CL0PS Sep 24 '19 at 17:51
  • 9
    it looks like the latest bios version is 7C37v14 (Release Date 2019-09-18). Do you have the latest bios? – Gordster Sep 24 '19 at 17:59
  • 10
    @Gordster Thanks for your help! Updating the BIOS did it (Ubuntu 19.04 btw) – B1CL0PS Sep 24 '19 at 18:09

It looks like the latest bios version is 7C37v14 (Release Date 2019-09-18). Update your bios to this version in order to get the latest Linux support.

With these processors and motherboards being so new it is a good idea to pay attention to the latest bios releases.

| improve this answer | |

Updating the BIOS to version 7C37v14 fixed the issue!

| improve this answer | |
  • 21
    Great that it worked for you. But please, don't just post this as another answer, instead accept the answer by Gordster by clicking on the tickmark below the votes. If you don't, the question will remain as "unanswered" in the system. – Gerald Schneider Sep 25 '19 at 10:03
  • 20
    @GeraldSchneider This answer was posted 10 minutes before the Gordster’s answer actually. However, since the advice came from Gordster’s comment, OP should really accept Gordster’s answer and remove their own. – Melebius Sep 25 '19 at 12:40
  • 5
    annoyingly, StackExchange makes you wait 2 days before accepting your answer. But it's done now. – B1CL0PS Sep 25 '19 at 20:14
  • 2
    You have to wait 2 days before accepting your own answer only, see askubuntu.com/help/self-answer. You can accept anyone else’s answer sooner. – Melebius Sep 26 '19 at 6:28

Modern distros like Ubuntu can have live USB disks made with dd. If even go so far as to say this is a superior way of doing it.

As root:

dd if=/path/to/iso.iso of=/dev/sdb 

Replace sdb with whatever your USB device is showing up as.

On mobile, but IIRC you can check with lsusb.

Edit: I thought this was a bug with unetbootin. It can be iffy sometimes.

| improve this answer | |
  • Or just cat /path/to/iso > /dev/sdb ;) – marcelm Sep 25 '19 at 23:04
  • I've always had success with DD over other tools. I would have recreated the usb as well if it wasn't for the fact that it was a new motherboard/processor – Gordster Sep 26 '19 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.