8

On a brand new Ubuntu 19.04, the latest chrome Version 77.0.3865.90 (Official Build) (64-bit) refuses to remember my selection. I'm trying to open a zoom URL, I'm getting the [Open xdg-open?] and just the action buttons without the checkbox to store my selection. I have removed ~/.config/google-chrome options in order to reset it but still same behavior

enter image description here

2
  • 1
    Did you find a solution. I've two machines with the same debian on and one is prompting without the option to remember too. – RichieHH Dec 8 '19 at 23:33
  • Well.. I know why it does that but I haven't found a solution. It's Google's stupidity I guess. They have disabled the checkbox to store your selection in version 77: support.google.com/chrome/thread/14193532?hl=en – Nick De Greek Dec 9 '19 at 20:47
0

Create following path and file:

sudo mkdir -p /etc/opt/chrome/policies/managed/
sudo touch /etc/opt/chrome/policies/managed/managed_policies.json

Open permissions for this file:

sudo chmod -R 775 /etc/opt/chrome/policies/managed

By default adding following content to this file should add the checkbox to remember your choice:

{
    "ExternalProtocolDialogShowAlwaysOpenCheckbox": true
}

This worked for all external website for me. For custom link, you may need to add those links to the whitelist:

{
    "ExternalProtocolDialogShowAlwaysOpenCheckbox": true,
    "URLWhitelist": [
        "telnet://*",
        "rvlink://*"
    ]
}

Same question on different community: Stop chrome from prompting when running external URL handler?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.