0

I'm having an issue with a dependencie of the MatLab runtime, it say that the libstdc++.so.6 need CXXABI_1.3.8.

I've seen some post that propose ton install an old version of GCC by adding a PPA, the probleme is that this PPA isn't avaible for the 19.04 version of ubuntu. Do you know any solution to get this dependencie working ?

4
  • 19.04 / g++-8. ..... objdump -x /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep CXXABI_1.3.8 ... The reply is 37 0x00 0x0bafd178 CXXABI_1.3.8 .. CXXABI_1.3.8 .... ?May be MatLab cannot search/usr/lib/x86_64-linux-gnu/ ? Sep 24, 2019 at 13:05
  • MatLab is not taking the libstdc++.so.6 in /usr/lib/x86_64-linux-gnu/ but in /usr/local/MATLAB/MATLAB_Runtime/v90/sys/os/glnxa64/. Maybe I can tell MatLab to get the right libstdc++.
    – Nemma
    Sep 24, 2019 at 13:20
  • Please try export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH && [other command] . ... I.e. this will set /usr/lib/x86_64-linux-gnu first in the search. Should work. Unless MatLab is hard coded to search only "/usr/local/MATLAB.... ... " Sep 24, 2019 at 13:56
  • Work just fine. Thank you a lot
    – Nemma
    Sep 24, 2019 at 13:58

1 Answer 1

1

Ubuntu 19.04, with g++-8

objdump -x /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep CXXABI_1.3.8 
37 0x00 0x0bafd178 CXXABI_1.3.8 
        CXXABI_1.3.8

Ref. MatLAB search: /usr/local/MATLAB/MATLAB_Runtime/v90/sys/os/glnxa64/

Please do :

export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH && [other command]

I.e. this will set /usr/lib/x86_64-linux-gnu/ first in the search path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.