2

I never noticed it until I upgraded to fiber. My phone pulls up to 400MBPS but my ubuntu is 150MBPS ish max. I read a (hell) lot of methods and issues and they increased my speed from 50 MBPS to what it is now.

At first, the wifi link speed was at 50 MBPS max but once I removed power saver and fixed a bug in avahi the link speed went to 477 MBPS, however internet speed (speedtest.net) is not as fast as my phone.

An ethernet cable pulls the same speed as my android, the problem is definetely wifi. Here are some problems I found :

Sep 24 11:42:11 -G3-3579 kernel: [    3.578600] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
Sep 24 11:42:11 -G3-3579 kernel: [    3.624291] iwlwifi 0000:00:14.3: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
Sep 24 11:42:11 -G3-3579 kernel: [    3.677257] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9462, REV=0x318
Sep 24 11:42:11 -G3-3579 kernel: [    3.726205] iwlwifi 0000:00:14.3: base HW address: a0:a4:c5:4c:43:f2
Sep 24 11:42:11 -G3-3579 kernel: [    4.245506] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
Sep 24 11:42:11 -G3-3579 NetworkManager[1003]: <info>  [1569318131.8016] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/ieee80211/phy0/rfkill1) (driver iwlwifi)
Sep 24 11:42:12 -G3-3579 kernel: [    6.359459] iwlwifi 0000:00:14.3: Conflict between TLV & NVM regarding enabling LAR (TLV = enabled NVM =disabled)
Sep 24 11:42:12 -G3-3579 kernel: [    6.363953] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
Sep 24 11:51:02 -G3-3579 NetworkManager[4508]: <info>  [1569318662.1277] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/ieee80211/phy0/rfkill1) (driver iwlwifi)
Sep 24 11:51:02 -G3-3579 kernel: [  535.921835] iwlwifi 0000:00:14.3: Conflict between TLV & NVM regarding enabling LAR (TLV = enabled NVM =disabled)
Sep 24 11:51:02 -G3-3579 kernel: [  535.930619] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS



lspci -nnk | grep 0280 -A3
00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
    Subsystem: Intel Corporation Device [8086:42a4]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Here's the guide I followed : https://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/

I'm on 18.04

2
  • 1
    Same here with .... 03:00.0 Network controller [0280]: Intel Corporation Wireless-AC 9260 [8086:2526] (rev 29) Subsystem: Intel Corporation Device [8086:4010] Kernel driver in use: iwlwifi Kernel modules: iwlwifi
    – dawid
    Dec 20, 2019 at 14:02
  • It seems that Ubuntu is keeping its tradition of breaking things with updates.
    – dawid
    Dec 20, 2019 at 14:04

1 Answer 1

1

I have the same exact Intel Wi-Fi module and this fixed the issue.

Edit /etc/modprobe.d/iwlwifi.conf and add the following at the end of the file options iwlwifi bt_coex_active=0

Then do sudo modprobe -r iwlwifi and sudo modprobe iwlwifi Or just reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.