2

I recently got a new computer and I have been trying to get a dual boot Windows/Ubuntu to work, so I got Ubuntu on a USB key( using Rufus as recommended in the Ubuntu page) but when I try to boot from the USB key and select Try Ubuntu without installing, I get the following error (and some variations of it)

Couldn't get size: 0x8000000000000e

BusyBox v1.27.2 (ubuntu 1:1.27.2-2ubuntu3.2) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) mount: mounting /cow on /root failed: invalid argument
overlay mount failed

I have tried with to different usb keys, and also disabling secure boot and fast boot.

After trying with nomodeset as recommended by sudodus, I get the following:

[    9.028870] Couldn't get size: 0x8000000000000e
[   13.311279] overlayfs: unrecognized mount option "lowerdir=" or missing value
BusyBox v1.27.2 (ubuntu 1:1.27.2-2ubuntu3.2) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) mount: mounting /cow on /root failed: invalid argument
overlay mount failed

I also have seen so post where people with a similar problem solved it by installing the appropriate GPU driver, but in that case the problem was after installing and rebooting, in my case I don't even get to install (or try it). Some info about the computer in case is relevant:

Asus FX505GD_FX505GD Intel i5-8300H 2.30Ghz Nvidia GeForce GTX 1050 4GB

The original OS was Microsoft Windows 10 Home

I'm happy to provide any other information, but I don't know what to look at.

Update: Following the answer of Akeo, I remove the persistence from the USB key and finally I manage to get into the try version of Ubuntu, but another problem appeared when I turned off Ubuntu ( from the try version, It was a bit late so I decided to install it later the next day). It took a long while ( about 3 min.) for the desktop to disappear (in the mean time it was frozen). When if finally disappeared I found this message(which again contains the Couldn't get size error):

enter image description here

and it continues:

This makes me worried about installing it from this USB key.

  • 2
    1. Please check with md5sum, that the downloaded iso file is correct; 2. You can try to clone from the iso file to the USB drive. Cloning is an option in Rufus 'dd-mode', or you can use Win32 Disk Imager – sudodus Sep 23 '19 at 19:22
  • 2
    On second thought, I think it is due to the nvidia graphics chip. Please add the boot option nomodeset. If still problems, Please check with md5sum, that the downloaded iso file is correct. – sudodus Sep 23 '19 at 19:27
  • @sudodus Thanks, I already check the ISO after the second time I tried to install it. I will try now with nomodeset. – themaker Sep 23 '19 at 19:30
  • @sudodus I tried with nomodeset, but it didn't work. I updated the question with the results. – themaker Sep 23 '19 at 19:51
  • 2
    You mention Ubuntu 18.04. Is it 18.04.3 or 'only' 18.04 which is older? Your nvidia chip will probably work better with a newer linux kernel and drivers for new hardware, so 18.04.3 has a better chance. You could even try the not yet released Ubuntu Eoan, to be released as 19.10 next month with an even newer linux kernel. See this link – sudodus Sep 23 '19 at 19:52
3

mount: mounting /cow on /root failed: invalid argument is what you typically get if you enabled persistence in Rufus (i.e. you set a persistent partition size that isn't zero) and are working with an ISO where Ubuntu/casper bug #1489855 has not been patched (which pretty much means every version of Ubuntu except the very latest 19.10).

If you want to use persistence with Ubuntu through a persistent partition that resides on the same media as the one you boot from, you must make sure that you use a version of Ubuntu where bug #1489855 has been fixed, which, right now, is only the case when using a daily-live ISO of 19.10 released after August 1st. I am not aware of any pre 19.10 ISO that includes the casper bugfix. Especially 18.04.03 will not work with a persistent partition because of the casper bug above.

Otherwise, either make sure that you set the persistent partition size to 0 in Rufus (no persistence) or use DD mode when prompted.

|improve this answer|||||
  • Thanks a lot, that definetely solved the original problem. Although I encountered a new one when I turn it off. I updated the answer with the problem( or maybe I should start a new question?). – themaker Sep 23 '19 at 22:36
0

Although is already marked as answered, I think this other option could be useful for people.

I had the same problem,Couldn't get size: 0x8000000000000e when trying to install ubuntu 18.04.3 alongside windows 10.

I made it work just using an ISO for ubuntu 18.04.1.

Hope this helps.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.