2

I've installed FFMPEG SNAP package (from Snapcrafters).

But it can't see/access any file in my home directory.

It always returns "filexyz.mp4: Permission denied" error . Doesn't not matter when I use sudo prefix or not.

FFMPEG installed from ubuntu repositories using sudo apt install ffmpeg worked. So this si snap package specific problem.

terminal screenshot here

6
  • right now, I have only workaround solution for this problem. When SNAP package is installed using --devmode attribute. Then it works and there is no "can't see any file" problem at all. So we have temporary solution here: sudo snap install ffmpeg --devmode Sep 23 '19 at 14:11
  • another workaround sollution is using IN/OUT pipes. cat input.mp4 | ffmpeg -i pipe:0 -f matroska pipe:1 | cat > output.mkv but it creates broken output files to me (its impossible to seek output files in media player and sometimes first keyframe is broken). Those outputs have to be fixed using mkvtoolnix ... Sep 23 '19 at 14:13
  • Can you try using absolute path and add escaping wherever necessary?
    – Yaron
    Sep 23 '19 at 14:30
  • Using absolute paths has no effect. Still returns "Permission denied" error Sep 23 '19 at 14:44
  • Can't duplicate, works fine here both with the stable and edge versions. Though am using 19.10 not 19.04. Did you install thru Ubuntu software or cli?
    – doug
    Sep 23 '19 at 16:24
6

There is no need to use --devmode or in/out pipes.

  1. Just open your graphical Software Center and find your FFMPEG app installed from SNAP repository.
  2. There you can find PERMISSIONS button, click on it, and enable "Read/write files on removable storage devices" permission. Then it works and you can read/write files in your own home directory.

More info about snap apps permissions here

This is bug, imo. Home directory is not "removable device" :-) But it works ...

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.