0

In Ubuntu 18.04, when several windows of the same application are initially minimized, and when I click on the application icon in dash-to-dock, all these minimized windows will appear altogether. This behaviour will result in a very messy desktop and require a user to have to minimize unwanted windows again.

Is there a way to just have just one of the application window appear instead of having the screen flooded with too many windows at once?

  • 1
    yes. It is the middle option in the extension settings for what to do on mouseclick?! You know where you find gnome extension setting, right? It is in gnome-tweaks -> extensions -> dashtodock gearsymbol. – mondjunge Sep 23 at 14:07
  • 1
    Right mouse click in dock will present a menu. Left click on All Windows and then select the one you want from what is displayed. – Graham Sep 23 at 14:19
  • 1
    @mondjunge Got it. dash-to-dock --> Behavior --> click-action --> gearwheel. Middle-Click action --> Show window previews . How do I do similar setting using gsettings? In dconf editor, I could not find Customize middle-click behaviour. – Sun Bear Sep 23 at 14:22
1

On the terminal, I discovered that I can use the below cmd to do what @mondjunge described for gnome-tweaks:

gsettings set org.gnome.shell.extensions.dash-to-dock middle-click-action 'previews'

Thus when I middle-click an App icon in dash-to-dock, a preview of opened App windows appears, and I can select the window I want to maximize from the preview.

  • 1
    A workaround, not the correct answer. – vanadium Sep 23 at 17:39
  • @vanadium do you have another solution in mind? Could you share it? Thanks. – Sun Bear Sep 23 at 19:39
  • For me, by default, a single window is activated. I thought i your case org.gnome.shell.extensions.dash-to-dock activate-single-window might be set to 'false', but in my case, that does not change the behaviour to what you describe (mind I am on 19.04). Check that setting. I was just suggesting that what you post is not a real solution, but only a workaround, which you should mention in your answer I think. – vanadium Sep 24 at 6:48
  • @vanadium The activate-single-window default value is true for dash-to-dock in Ubuntu 18.04 too. Toggling it had no effect; also did not do what I wanted. It seems @mondjunge solution is the only viable solution; the gsettings cmd I wrote here is the cmdline way to achieving @mondjunge solution. – Sun Bear Sep 24 at 8:23
  • On 19.04, I cannot reproduce your issue, even if all windows effectively are minimized. The dock always brings a single window on the front, a subsequent one with each subsequent click. So this may indeed be an issue in 18.04 that has been solved. – vanadium Sep 25 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.