I have used this procedure to change the root password:

  1. Get to GRUB screen
  2. Press e to edit
  3. add rw init=/bin/bash to end of the kernel line
  4. ctrl-x to reboot
  5. from there I would mount -rw -o remount / then passwd, etc...

That has worked in the past. This time I get:

bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

Then nothing. No response to any keyboard entry.

I also tried to boot to the recovery mode but when I hit to "Drop to root shell prompt", it shows me the message:

Give root password for maintenance (or type Control-D to continue)
  • @Melebius I also checked this but when I came "Drop to root shell prompt" it wants from me to write root password.
    – Cebrayil
    Sep 23, 2019 at 13:52
  • I checked this @Fabbyit requires root password.
    – Cebrayil
    Sep 24, 2019 at 5:27
  • @Melebius I am using the arrow keys scroll down to root when I hit to "Drop to root shell prompt" ,it shows me "Give root password for maintenance (or type Control-D to continue)" message
    – Cebrayil
    Sep 24, 2019 at 7:23
  • 1
    Normally Ubuntu has not activated log in as user root. Instead you are encouraged to have at least one user, that can use sudo (with their own user password). Maybe there is a userID with sudo permissions, that can do system tasks.
    – sudodus
    Sep 24, 2019 at 8:15
  • 1
    None of the so called duplicates are helpful at all because eventually they just come down "use init=/bin/bash" which then drops you to this ioctl message and that's the end of it because after tihis error message bash doesn't accept any keystrokes. Not even ctrl+alt+del.
    – chx
    May 7, 2020 at 3:22


Browse other questions tagged or ask your own question.