2

I am trying to install ImageMagick in my Ubuntu 18.04.1, following the instructions in this link.

After running the following command

./configure

I am getting the following errors:

configure: error: in `/home/bharath/src/ImageMagick-7.0.8-66':
configure: error: libltdl is required for modules and OpenCL builds
See `config.log' for more details

Could anyone tell how to fix these errors?

  • 7
    Unless you specifically need a different version, you should probably install the pre-built binary imagemagick package from the Ubuntu repository instead of trying to build it from source – steeldriver Sep 23 at 12:33
  • Why is this tagged 14.04? – fkraiem Sep 23 at 13:07
  • @fkraiem Probably by mistake. I have suggested an edit to fix this. Waiting to be approved. – user3140225 Sep 23 at 13:55
9

As steeldriver suggests in his comment, you should probably install imagemagick from the official Ubuntu repositories, by running:

sudo apt install imagemagick

However, if you still need to install imagemagick from source, just install the libltdl development package, as the error suggests, by running:

sudo apt install libltdl-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.