1

I'm looking for a way to prevent my notification tone from playing when I run into something like hitting backspace in the terminal when there aren't any characters. When I do that, it plays the error tone and my notification tone. Is there a way to prevent this?

I am using Ubuntu 18.04.03 with GNOME 3.43

EDIT: I want to keep using the tone for notifications such as in Calendar or Evolution.

  • i.stack.imgur.com/ZlEmO.gif if it is only for terminal notification tone.. uncheck the Terminal Bell from Terminal Preferences Tab – UnKNOWn Sep 23 '19 at 10:42
  • @CStafford-14 Please click edit and advise which version of Ubuntu you are using. If we guess wrong, we can mislead you. – K7AAY Sep 23 '19 at 16:49
0

Without having the details of the specific flavour of Ubuntu (incl. desktop environment) that is in use (OP should edit answer to provide details), have a look at this existing post for Ubuntu 18.04 -> Turn off error sound on Ubuntu 18.04. This allows you to disable the desktop notification sounds, that may exist in addition to the generic system bell.

Check for duplicate sounds added by the (obsolete) pcspkr module perhaps? It is no longer included by default, so:

lsmod | grep pcspkr

should return no matches.

More generically, via the CLI, you can also disable the (tab-completion) bell in terminals by editing /etc/inputrc as root and un-commenting the line:

set bell-style none

To accomplish the same as a normal user, in Bash terminals, add the same code via bind to your .bashrc file, as suggested in the linked post.

| improve this answer | |
1

Go to Settings → Sound → select Sound Effects tab

enter image description here

Choose Alert Volume and set to OFF (or at least reduce the volume)

| improve this answer | |
  • I'd like to keep my notification tone... Otherwise, that's what I'd do. OR... could I still have it as the notification tone? – CStafford-14 Sep 24 '19 at 16:22
  • @CStafford-14 You could just adjust the Alert Volume if you wish to keep it going. – User24601 Sep 24 '19 at 17:18
  • I could, but the others gave me a better answer. Thanks for the tip, though! – CStafford-14 Sep 24 '19 at 17:25
  • @CStafford-14 Glad to have been of some help in resolving this issue for you. – User24601 Sep 24 '19 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.