0

System info

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:    18.04
Codename:   bionic

Tried building kde connect from source

after i run

sudo apt-get build-dep kdeconnect

i get

Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:kdeconnect : Depends: libqca2-plugin-ossl but it is not installable
E: Unable to correct problems, you have held broken packages.

Tried installing from

  1. How to Use KDE Connect with MATE on Ubuntu and Debian
  2. Install KDE Connect in Ubuntu 18.04
  3. How to install KDE connect in ubuntu 17.04?

All the mentioned unable to launch kde connect indicator or kde connect

Please guide

marked as duplicate by N0rbert, Fabby, karel, Eliah Kagan, Kulfy Sep 25 at 8:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please add output of apt-cache policy kdeconnect to the question. – N0rbert Sep 23 at 19:31
0

I suppose that you forgot to add universe repository. The kdeconnect package is located in it in all current Ubuntu versions.

You have to:

  1. add the repository with sudo add-apt-repository universe
  2. install KDE Connect with sudo apt-get install kdeconnect
  • I get this 'universe' distribution component is already enabled for all sources. on running sudo add-apt-repository universe – Santhosh Dhaipule Chandrakanth Sep 23 at 3:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.