0

I have an ESXi 6.7 with 6 VMs.
One of the VMs is configured with Ubuntu 18.04 updated.
I am following this instructions to the letter https://ubuntu.com/openstack/install
I use virsh as power type

Power type: Virsh (virtual system)
Virsh Address: esx://root@192.168.40.9/?no_verify=1>
Virsh password: xxxxx Virsh VM Id: "VM name on Esxi"

MAAS is controlling the VMs perfectly, I can deploy Ubuntu18.04 with no problems and SSH to it.
All machines are in "Ready state"

I have tried with this versions of conjure-up

sudo snap install conjure-up --classic
sudo snap install conjure-up --classic --beta
sudo snap install conjure-up --classic --edge
sudo snap refresh conjure-up --classic --edge
sudo snap refresh conjure-up --classic --beta

It always fails when juju is lauching the Neutron-api in the LXD container.

I am trying with this Guide also: https://docs.openstack.org/project-deploy-guide/charm-deployment-guide/stein/

I have tried with all this juju versions:

sudo snap install juju --classic
sudo snap install juju --beta --classic
sudo snap install juju --edge --classic

After following this page: https://docs.openstack.org/project-deploy-guide/charm-deployment-guide/stein/install-openstack.html#deploy-the-juju-controller
The moment I launch this command, juju stops and I loose connectivity to the host where the neutron-api should be launched.

juju deploy --to lxd:1 --config neutron.yaml neutron-api

It always fails when juju is lauching the Neutron-api in the LXD container.

Help, I need somebody. Help.

0

I fixed the problem and I want to share the solution in case somebody else need it.
What I did was to try to configure a Neutron network manually in a LXD container to try to figure out where was the problem.
The first thing that you need. Is to have is a bridge in Your host to provide networking to your LXD VMs.
But if You do not have "Promiscuous mode" Enabled on your VMware Vswitch then Your bridge is not going to work and you will loose all network connectivity on your host.
So Always enable Promiscuous mode when you are creating Bridges in your Virtual MAchines.
After enabling "Promiscuous mode" all my problems went away.
Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.