I'm currently on Ubuntu 16.04. I'm trying to install wpscan. I already have ruby but it's v.2.3.1 (default). I've tried both suggested methods, gem install wpscan and "from sources". In both cases, I've encountered the error:

ERROR:  Error installing wpscan:
    zeitwerk requires Ruby version >= 2.4.4.

I've tried several things to install or upgrade Ruby:

sudo apt install ruby-full
sudo apt install rubygems

I don't actually use Ruby besides running my tools made by others so I'm not sure how Ruby's system works.

How should I upgrade my Ruby version to >= 2.4.4 to run wpscan?


1 Answer 1


You have two possible paths.

1) Use Ubuntu Snap rather than Apt - it'll allow you to choose which version to install, the latest or any prior one. See The official Ruby snap is available post on the Ruby.org website for instructions. Main advantage is it's officially supported both by Ruby.org and Ubuntu.

2) If you prefer to stick with Debian's Apt package management tool, you can rely on Brightbox PPA Ruby packages for Ubuntu which gives you almost the same choices (at present, they have yet to provide the very recent version 2.7). Here you'd have to rely on Brightbox to continue providing optimized Ruby packages for Ubuntu as they have done for years.

Like you, I'm using tools written in Ruby by others and, in my experience, the installation of Ruby Gems can be far from trivial.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .