1

I’m trying to replace Windows 10 with Ubuntu 19.04. I have a new HP Pavilion x360 laptop with 4GB ram. I’ve been looking at tutorials on how to download Ubuntu yet I'm still having trouble installing.

I don’t have the ‘delete Windows and install Ubuntu’ option. It just takes me to language options, WiFi setup, then installation type where I have to manually input the partitions.

In the ‘device for boot loader installation’ it’s only giving me 15.7 gb (probably from my USB), instead of the unallocated space I made on Windows. Ubuntu can’t seem to find the allocated space, and I’ve scrolled countless of forums and tried every command recommended to me.

Does anyone have a solution or an alternative?

(Windows is not on hibernation/sleep mode. SAMA operations is not an option on Windows 10 anymore. I’ve already fixed everything on the BIOS. Can I just download Ubuntu without dual booting or USB...)

0

Here's the official LiveUSB download-and-create tutorial and the official installation tutorial. You should follow and complete the first before starting the second.

In the installation, you will not see "Delete Windows and install Ubuntu", it's "Erase disk and install Ubuntu" as shown in this step of the install tutorial. However, since you altered the disk partitions in Windows, you should choose "Something Else" and then look for a spin box at upper right which lets you select which drive you will install to.

| improve this answer | |
  • I would choose “erase disk and install Ubuntu” if I saw it, but it’s not there. I’ve followed those steps and I got the same result: difficulty finding the allocated space i’ve made. – Xreph Sep 21 '19 at 2:52
0

Okay, so I figured out what I was doing wrong. Turns out I was doing everything with the Windows tool, which Ubuntu is unable to process made unallocated spaces from.

  1. I downloaded 'Minitool Partition Wizard', resized the partition to my liking, and formatted the newly created partition as 'ext4'.

  2. Booted up to Ubuntu and saw that it still wasn't showing up on the 'disks' application. Then I noticed something called 'GParted', an application that came pre-installed with Ubunutu.

  3. The unallocated space I made with 'MPW' was there. I still needed to format it back to 'ext4' with mount point / .

  4. It appeared on 'disks' and I mounted the partition.

I clicked to install Ubuntu and was glad to finally be meet with the 'installation type' screen. I chose my preferred option and Ubuntu was able to set my partitions itself and install perfectly. Hope this helps anyone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.