I am running Ubuntu 18.04.3 LTS and when I launch MATLAB R2019b I get the following error:

Gtk-Message: 00:20:10.283: Failed to load module "canberra-gtk-module" [0921/002013.995543:INFO:context.cpp(159)] Using multi-threaded message loop for Linux

I read this thread: Failed to load module “canberra-gtk-module” .... but already installed

but wasn't able to resolve the issue. Matlab launches and then it functions well but I would like to solve this error. Any ideas would be appreciated.

  • It may be caused by 32-bit versions of the libraries. Try sudo apt install libcanberra-gtk-module:i386 libcanberra-gtk3-module:i386.
    – N0rbert
    Sep 21, 2019 at 11:21
  • Actually, this didn't resolve the issue. It still persists. Nov 27, 2020 at 14:34

2 Answers 2


Not a an issue unique to Matlab, but Ubuntu. It is solved by executing:

  • sudo apt-get install libcanberra-gtk-module

So the answer is in a terminal excecute the following

sudo apt-get install libcanberra-gtk* libgconf-2-4
sudo ln -s /usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so /usr/lib/libcanberra-gtk-module.so

The second line will create a link to the module. Matlab works with gtk-2.0 module. For other linux distributions follow this. Problem solved, at least for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .