1

I'm running a fresh new installed Ubuntu 18.04.3. So my problem is: when I install texstudio with terminal in the usual way everything seems to run smoothly:

zosiah@zosiah-HP-255-G6-Notebook-PC:~$ sudo apt install texstudio
[sudo] password for zosiah: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libqt5concurrent5
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  texstudio-l10n
Suggested packages:
  latex-beamer
The following NEW packages will be installed:
  texstudio texstudio-l10n
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/5.775 kB of archives.
After this operation, 16,5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 365865 files and directories currently installed.)
Preparing to unpack .../texstudio_2.12.6+debian-2_amd64.deb ...
Unpacking texstudio (2.12.6+debian-2) ...
Selecting previously unselected package texstudio-l10n.
Preparing to unpack .../texstudio-l10n_2.12.6+debian-2_all.deb ...
Unpacking texstudio-l10n (2.12.6+debian-2) ...
Setting up texstudio (2.12.6+debian-2) ...
Setting up texstudio-l10n (2.12.6+debian-2) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...

but when I try to run texstudio terminal says:

zosiah@zosiah-HP-255-G6-Notebook-PC:~$ texstudio
texstudio: error while loading shared libraries: libdouble-conversion.so.1: cannot open shared object file: No such file or directory

I've been googling around for a while but I've not arrived to a solution... Any idea? P.S. I'm not being able to install texmaker and emacs25, too. This thing sounds to me pretty strange because until now I've never had such problem neither wit synaptic nor with apt and so on... What could be the matter?

EDIT: Hi N0rbert, thanks for replying! Here follow requested outputs:

zosiah@zosiah-HP-255-G6-Notebook-PC:~$ which texstudio
/usr/bin/texstudio
zosiah@zosiah-HP-255-G6-Notebook-PC:~$ ldd $(which texstudio) | grep not

(no output here)

zosiah@zosiah-HP-255-G6-Notebook-PC:~$ apt-cache policy texstudio libdouble-conversion1
texstudio:
  Installed: 2.12.6+debian-2
  Candidate: 2.12.6+debian-2
  Version table:
 *** 2.12.6+debian-2 500
        500 http://it.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libdouble-conversion1:
  Installed: 2.0.1-4ubuntu1
  Candidate: 2.0.1-4ubuntu1
  Version table:
 *** 2.0.1-4ubuntu1 500
        500 http://it.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

EDIT 2 I'm adding the output of ldd $(locate libdouble-conversion.so.1):

zosiah@zosiah-HP-255-G6-Notebook-PC:~$ ldd $(locate libdouble-conversion.so.1)
/usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1:
    linux-vdso.so.1 (0x00007ffe54bc4000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f80a84b9000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f80a8119000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f80a7d21000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f80a8a61000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f80a7b09000)
/usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1.0:
    linux-vdso.so.1 (0x00007ffcb9ee4000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fa819d01000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fa819961000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fa819569000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fa81a2a9000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fa819351000)

EDIT 3 : PROBLEM SOLVED after reinstalling a library with the following terminal command:

sudo apt install --reinstall libxcb-xinerama0
  • 1
    Please add output of which texstudio, ldd $(which texstudio) | grep not, apt-cache policy texstudio libdouble-conversion1 to the question. – N0rbert Sep 20 '19 at 19:27
  • Please also add output of ldd $(locate libdouble-conversion.so.1) to the question. – N0rbert Sep 22 '19 at 9:51
  • Consider to write your own answer with solution to help other users. – N0rbert Sep 22 '19 at 21:26
0

Problem solved just reinstalling the library libxcb-xinerama0 with the following terminal command:

sudo apt install --reinstall libxcb-xinerama0
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.