3

Whenever I utilize any (except for --version) adb command (adb devices, for instance), my system completely freezes and I have to reboot. My laptop is a Lenovo B50-30 running a (relatively) fresh Ubuntu 18.04 installation, no phones are connected. What do I have to do in order to get adb working ?

What I have already tried :

  • Connecting phone
  • Changing BIOS settings - disabled legacy USB & changed legacy to UEFI boot
  • Running adb using sudo
  • Removing tlp (sudo apt remove tlp)
  • Checking whether port is in use (sudo netstat -tulpn | grep 5037)
  • Upgrading adb (sudo apt upgrade adb)
  • Running different adb commands

Update : I have tried a different computer with (relatively similar) specs but an older Ubuntu (16.04) and also an older kernel, and it worked pretty much seamlessly.

Related :

3

Old question but I was stuck with this problem too. So I found what's causing it: the BIOS.

There should be a option to enable/disabe xHCI Support - enable /disable external USB3.0 Controller.

If it's disabled, adb won't freeze the OS

1
  • I unfortunately can't test this anymore as my old device died, and it is working flawlessly on my new one – LMD Aug 11 '20 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.