I am trying to install Ubuntu 18.04.3 on dual boot along with Windows 10. My system is a legacy bios. Ubuntu does not identify that there is Windows installed on the system and thus I do not get the option to install Ubuntu alongside Windows. I've tried creating the disk partitions manually but I get the following error:

enter image description here

I think the problem is that Ubuntu installation opens in EFI mode (I see a black and white GRUB screen). The partition of my bootable pendrive is MBR. I've tried creating the bootable pendrive with Rufus, Yumi and Universal USB Installer without any success. Any idea what should I do to resolve this? Any help will be appreciated.


  • 1
    This usually happens when windows is not fully shut down. By default, windows is set to a "fast boot" setting that prevents windows from shutting down fully to speed up the boot process. You need to disable this setting in windows before you begin the installation. Did you already disable this option in windows and fully shut windows down properly?
    – mchid
    Sep 20, 2019 at 10:23
  • Here are some instructions on how to disable fastboot: computerhope.com/issues/ch001762.htm After you disable fastboot, do not hibernate or suspend. You must fully shut windows down before you begin the installation. If this works, let me know and I will post this as the answer. Thanks!
    – mchid
    Sep 20, 2019 at 10:26
  • Thanks for the response. I turned off my fast boot option but the problem still persists.
    – Susan94
    Sep 20, 2019 at 16:28
  • Also, you say that the pendrive is MBR. If you want to install "along side" windows, the fact that the pendrive is MBR does not matter. You should not set your BIOS to "legacy mode" but you do need to set your uefi settings to disable secure-boot. Here are some instructions: fossbytes.com/enable-disable-secure-boot-windows-8-10 Please let me know if this works. Thanks!
    – mchid
    Sep 20, 2019 at 23:03
  • Does your computer have the ability to use UEFI? If so, in the BIOS settings, set UEFI to ON and SECURE BOOT to OFF.
    – mchid
    Sep 21, 2019 at 1:37

1 Answer 1


Try this trick https://askubuntu.com/a/1266315/1114033 it's solved my problem to installing Xubuntu on legacy Bios. When installer checking and got error (can't found 3 files on EFI folder), ignore it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .