0

Tried updated kernel to 5.1 and 5.2. Currently:

uname -a
... 5.1.21-050121-generic ...

I also installed the latest firmware:

ls /lib/firmware/ | grep iwlwifi-cc-a0
iwlwifi-cc-a0-46.ucode

Running out of ideas here... Also confirmed that secure boot is disabled.

dmesg | grep iwlwifi
[] iwlwifi: 0000:02:00.0: enabling device (0000 -> 0002)
[] iwlwifi: probe of 0000:02:00.0 failed with error -110

Let me know what else I can check. Considering returning the laptop (razer 15) at this point since I need ubuntu running on it.

0

I went out and got a usb-ethernet adapter (LIFE SAVER! Will cherish this thing) and doing a apt-get update and apt-get upgrade.

I then updated to kernel 5.1.16 and put the latest firmware for AX200 into my /lib/firmware directory. I don't know which step absolutely fixed it (doing apt-get update/upgrade or using kernel 5.1.16 specifically; but I think it was the former probably), but it now magically works:

dmesg | grep wifi
[    3.164561] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[    3.175839] iwlwifi 0000:02:00.0: loaded firmware version 46.3cfab8da.0 op_mode iwlmvm
[    3.196234] iwlwifi 0000:02:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340

Hopefully this will help others to get this working because I was on the verge of returning this laptop...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.