1

How to install Ubuntu on a dell latitude 5400 with WD SN520 NVMe SSD?

The drive is not recognised by the installer as present (neither with ubuntu 18.04 LTS, nor Ubuntu 19.04, nor Debian 10.1 (nonfree=with all drivers), nor Fedora 30, nor RHEL 8.)

Windows 10 is installed, secure boot disabled as usual for installing linux but the drive is not found. Tried: bios: intel RAID (is default, needed for windows 10 to boot), AHCI and disabled. Disable all other diskcontrollers. BIOS reset, factory reset and again just disabled secure boot.

(Dell says they give only Ubuntu/linux support for PC's shipped with Linux.)

I actually don't even need dual boot, just get it to recognize the disk and boot linux from it.

Extra information:

  • I called Dell support about this, their answer: "This machine is not shipped with Linux, we don't give support for Linux on it. There is a selection of laptops and desktops available with Ubuntu preloaded only those get support for Ubuntu."
  • I made ticket wit Western Digital about this, they don't have a Linux driver available on their site for this hardware. I await their response
  • I also contacted Redhat support: they don't want to investigate further without a paid subscription.
  • I have a previous version of a similar machine with a samsung NVMe SSD this was installed without an issue.
  • (I did an "lspci" but it appears the disk is not visual there, but neither is it on the machine with the working samsung NVMe drive)

Apparently in the users forum of Western Digital this is mentioned and WD appears to have no support/no driver for linux, the suggested solution is: replace the disk with a Samsung NVMe:

4
  • 1
    See askubuntu.com/questions/1051205/…. Is this the same problem?
    – Jos
    Sep 19, 2019 at 9:18
  • Well @Jos It could be, I think it is due to no linux support/no driver by WD themselves
    – jringoot
    Sep 19, 2019 at 21:22
  • @user68186 it is indepent from RAID/AHCI settings, furthermore, these are SATA standards and the "problem disk" is not a SATA disk but an NMVe disk Nevertheless, I tested this in BIOS, tried all positions for the SATA interface as well, because you never now, but this didn't help.
    – jringoot
    Sep 24, 2019 at 5:16
  • I found this answer helped me with a very similar problem: superuser.com/a/1359471/351539 Nov 8, 2021 at 11:14

1 Answer 1

1

After doing a test with another disk from an older machine (also a dell but another smaller nvme (toshiba)) were installation was succesfull. I checked again on the Dell support site and found a new BIOS firmware, released last week. I applied it and it and booted with Linux installation media, and successfully installed on the WD nvme. I am not sure but I suspect that this firmware enables the mainboard to force the disk to go to previous/simpler version of power managment when the OS does not support the P4 standard (APST or PCIe Active State Power Management (ASPM)) Like mentioned in this comment

Nevertheless, SATA interface must be set to AHCI instead of RAID.

I know this is bizarre (=The NVMe is using a separate PCI express interface on the north bridge and not SATA which is on the south bridge, how can this setting on the southbridge chipset influence a north bridge interface?) But it works.

1
  • what is your bios version ?
    – Fat Mind
    Sep 1, 2020 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.