1

On 10 HP Prodesk 600 G3 PCs with i5 3.4GHz CPUs, NVMe disks, and Ubuntu 17, I've been running Ubuntu 17 for an examination system. In order to upgrade Virtualbox, I had to upgrade 17 -> 18. Except, it didn't work. In the end, I always end up with an error telling that grub cannot been installed. I can install 17, without any problem, but I can't install anything on 17. Tried 19, and same thing, didn't install grub.

I have tried A LOT of suggested fixes here, but no go. It ends with not installing grub in the end of installing process. And yes, I have manually partitioned the disk, I have tried via Live-USB to install Ubuntu (UEFI) and manually install grub. I have tried the Super Grub2, ends with same error. Firmware is updated, any hint concerning this very model would help a lot.

Peter

edit: I pretty much tried everything about this topic found here, nothing worked. I choose the simplest installation, erase the disk, and get:

The partition tables on the following devices are changed: /dev/nvme0n1

The following partitions are going to be formated: partition#1 of /dev/nvme01 as ESP partition#2 of /dev/nvme01 as ext4

Files are being copied, and in the end it comes to:

"The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot."

No matter what I try, it ends up like this. Except for Ubuntu 17 of course, then it is up and running in minutes...

I've partitioned manually, tried many alternatives, booted Legacy and UEFI, changed usb-memories, downloaded image several times, and now I'm out of ideas...

Edit: thought I'd try to install 17, went fine again, and install 18 alongside, maybe adding 18 to existing grub would fix it, but no. Same error...

  • It's very helpful for us to know exactly what you tried (including the specfici commands) and the exact error messages. Please click edit and update the question with that infor. Please don't use Add Comment; instead, use edit. – K7AAY Sep 18 '19 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.